summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc-Olivier Barre2021-02-16 11:36:25 +0100
committerMarc-Olivier Barre2021-02-16 11:36:25 +0100
commite9e146e16d14f15c57db16f0c1d0807a4bed569e (patch)
tree0f4256272cbbd2a849df394f3f37b61281f3321c
downloadaur-e9e146e16d14f15c57db16f0c1d0807a4bed569e.tar.gz
Initial package release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75d34aec503f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libindi-qhy
+ pkgdesc = 3rd party drivers for INDI: QHY
+ pkgver = 1.8.8
+ pkgrel = 1
+ url = http://www.indilib.org/index.php?title=Main_Page
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = libindi=1.8.8
+ depends = libqhy
+ source = https://github.com/indilib/indi-3rdparty/archive/v1.8.8.tar.gz
+ sha256sums = 0a50aff683e4e76d12b7558076734ace3c4340d93fcab2c25c8a7c0bc3d53816
+
+pkgname = libindi-qhy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2316ee3cfafa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Sebastian Baberowski <sebastian@baberowski.com>
+
+pkgname=libindi-qhy
+pkgver=1.8.8
+pkgrel=1
+pkgdesc="3rd party drivers for INDI: QHY"
+url="http://www.indilib.org/index.php?title=Main_Page"
+license=(GPL2)
+arch=(i686 x86_64)
+depends=(libindi=${pkgver} libqhy)
+makedepends=(cmake)
+source=("https://github.com/indilib/indi-3rdparty/archive/v${pkgver}.tar.gz")
+sha256sums=("0a50aff683e4e76d12b7558076734ace3c4340d93fcab2c25c8a7c0bc3d53816")
+
+prepare() {
+ mkdir -p build
+ cd indi-3rdparty-${pkgver}
+
+ #set all to off by default
+ sed -i -e '/option(WITH_.*On/s/ On/ Off/' CMakeLists.txt
+}
+
+build() {
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_QHY=On \
+ ../indi-3rdparty-${pkgver}
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}