summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc-Olivier Barre2022-02-27 12:32:51 +0100
committerMarc-Olivier Barre2022-02-27 12:32:51 +0100
commit3cf603efe5492636e8f4d6905bfa3917f1fd70e3 (patch)
tree18cd3537d5bd84e4eca2252e6661879b34e3eeca
parented3ef83d07a5a79a353c9394c856aa310ae50a24 (diff)
downloadaur-3cf603efe5492636e8f4d6905bfa3917f1fd70e3.tar.gz
Bump to 1.9.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--celestronaux-auxproto.diff11
-rw-r--r--ffmpeg-5.diff107
4 files changed, 130 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02b892d04623..44f72614a702 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libindi_3rdparty
pkgdesc = 3rd party drivers for INDI, a distributed control protocol designed to operate astronomical instrumentation
- pkgver = 1.9.3
+ pkgver = 1.9.4
pkgrel = 1
url = http://www.indilib.org/index.php?title=Main_Page
arch = i686
@@ -23,7 +23,11 @@ pkgbase = libindi_3rdparty
depends = gpsd
provides = libindi_3rdparty
conflicts = libqhy-git
- source = https://github.com/indilib/indi-3rdparty/archive/v1.9.3.tar.gz
- sha256sums = 4e71a8106fcdf6248486b18f04f4013332b0722b4942b90fbf01770d8037d3dc
+ source = https://github.com/indilib/indi-3rdparty/archive/v1.9.4.tar.gz
+ source = celestronaux-auxproto.diff
+ source = ffmpeg-5.diff
+ sha256sums = 10ed5e6c3a306bd77c8e39d40a942dd166ae623b12bcd6bd52b871b7ba8c908b
+ sha256sums = fef4fe62933872bbf6424e8ee538363d38288ed12fce0222fd566bcb5a4bf372
+ sha256sums = 5a9881a46cf971e9cf31ebf76ae376d66f1463d2c7b8bc847eb97ff11c07f37c
pkgname = libindi_3rdparty
diff --git a/PKGBUILD b/PKGBUILD
index 942e5cc47682..813df2c050ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Peter Strapp <peter at strapp.co.uk>
pkgname=libindi_3rdparty
-pkgver=1.9.3
+pkgver=1.9.4
pkgrel=1
pkgdesc="3rd party drivers for INDI, a distributed control protocol designed to operate astronomical instrumentation"
provides=('libindi_3rdparty')
@@ -12,13 +12,15 @@ arch=(i686 x86_64)
depends=(libvorbis libusb openal libnova libjpeg libindi libgphoto2 libftdi-compat cfitsio dcraw libftdi rtl-sdr gpsd)
makedepends=(cmake boost)
conflicts=(libqhy-git)
-source=("https://github.com/indilib/indi-3rdparty/archive/v${pkgver}.tar.gz")
-sha256sums=("4e71a8106fcdf6248486b18f04f4013332b0722b4942b90fbf01770d8037d3dc")
+source=("https://github.com/indilib/indi-3rdparty/archive/v${pkgver}.tar.gz" "celestronaux-auxproto.diff" "ffmpeg-5.diff")
+sha256sums=("10ed5e6c3a306bd77c8e39d40a942dd166ae623b12bcd6bd52b871b7ba8c908b" "fef4fe62933872bbf6424e8ee538363d38288ed12fce0222fd566bcb5a4bf372" "5a9881a46cf971e9cf31ebf76ae376d66f1463d2c7b8bc847eb97ff11c07f37c")
prepare() {
mkdir -p build
cd indi-3rdparty-${pkgver}
+ patch -Np1 < ${srcdir}/celestronaux-auxproto.diff
+ patch -Np1 < ${srcdir}/ffmpeg-5.diff
find ./ -name CMakeLists.txt -exec sed -i -e 's|"\/lib|"${CMAKE_INSTALL_PREFIX}/lib|g' {} \; # Allow installing outside of /lib
}
diff --git a/celestronaux-auxproto.diff b/celestronaux-auxproto.diff
new file mode 100644
index 000000000000..4156857210d9
--- /dev/null
+++ b/celestronaux-auxproto.diff
@@ -0,0 +1,11 @@
+diff --color -ru a/indi-celestronaux/auxproto.h b/indi-celestronaux/auxproto.h
+--- a/indi-celestronaux/auxproto.h 2022-02-27 11:56:58.957641841 +0100
++++ b/indi-celestronaux/auxproto.h 2022-02-27 11:54:58.106674975 +0100
+@@ -25,6 +25,7 @@
+
+ #include <vector>
+ #include <stdint.h>
++#include <cstddef>
+
+ typedef std::vector<uint8_t> AUXBuffer;
+
diff --git a/ffmpeg-5.diff b/ffmpeg-5.diff
new file mode 100644
index 000000000000..0c57f9756192
--- /dev/null
+++ b/ffmpeg-5.diff
@@ -0,0 +1,107 @@
+diff --color -ru a/indi-webcam/indi_webcam.cpp b/indi-webcam/indi_webcam.cpp
+--- a/indi-webcam/indi_webcam.cpp 2022-01-17 05:16:50.000000000 +0100
++++ b/indi-webcam/indi_webcam.cpp 2022-02-27 12:24:43.601908037 +0100
+@@ -125,7 +125,11 @@
+ //This set of commands should open the avfoundation device to list its sources
+ AVDictionary* options = nullptr;
+ av_dict_set(&options,"list_devices","true",0);
++#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(59, 0, 100)
+ AVInputFormat *iformat = av_find_input_format("avfoundation");
++#else
++ const AVInputFormat *iformat = av_find_input_format("avfoundation");
++#endif
+ avformat_open_input(&pFormatCtx,"",iformat,&options);
+ avformat_close_input(&pFormatCtx);
+ checkingDevices = false;
+@@ -154,11 +158,15 @@
+ buffer = nullptr;
+
+ // These calls are depreciated, but are required for some older FFMPEG distributions on Linux
++#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(58, 9, 100)
+ av_register_all();
++#endif
+ //This registers all devices
+ avdevice_register_all();
+ //This registers all codecs
++#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(58, 9, 100)
+ avcodec_register_all();
++#endif
+
+ //This call is required for the IP Camera functionality to work
+ avformat_network_init();
+@@ -238,7 +246,11 @@
+
+ AVDictionary* options = nullptr;
+ av_dict_set(&options, "timeout", ffmpegTimeout.c_str(), 0); //Timeout for open_input and for read_frame. VERY important.
++#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(59, 0, 100)
+ AVInputFormat *iformat = nullptr;
++#else
++ const AVInputFormat *iformat = nullptr;
++#endif
+ if(device != "IP Camera")
+ {
+ //These items are not used by an IP Camera
+@@ -506,7 +518,11 @@
+ //This refreshes the input device list
+ bool indi_webcam::refreshInputDevices()
+ {
++#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(59, 0, 100)
+ AVInputFormat * d=nullptr;
++#else
++ const AVInputFormat * d=nullptr;
++#endif
+ int i =0;
+ int numDevices = getNumOfInputDevices();
+ CaptureDevices = new ISwitch[numDevices + 1];
+@@ -530,7 +546,11 @@
+ int indi_webcam::getNumOfInputDevices()
+ {
+ int i = 0;
++#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(59, 0, 100)
+ AVInputFormat * d=nullptr;
++#else
++ const AVInputFormat * d=nullptr;
++#endif
+ while ((d = av_input_video_device_next(d)))
+ {
+ i++;
+@@ -575,7 +595,11 @@
+ {
+ int nbdev=0;
+ struct AVDeviceInfoList *devlist = nullptr;
++#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(59, 0, 100)
+ AVInputFormat *iformat = av_find_input_format(videoDevice.c_str());
++#else
++ const AVInputFormat *iformat = av_find_input_format(videoDevice.c_str());
++#endif
+ nbdev=avdevice_list_input_sources(iformat, nullptr, nullptr, &devlist);
+
+ //For this case the source list function is not implemented, we have to just list them by number
+@@ -1668,3 +1692,4 @@
+
+ return true;
+ }
++
+diff --color -ru a/indi-webcam/indi_webcam.h b/indi-webcam/indi_webcam.h
+--- a/indi-webcam/indi_webcam.h 2022-01-17 05:16:50.000000000 +0100
++++ b/indi-webcam/indi_webcam.h 2022-02-27 12:30:56.733044539 +0100
+@@ -36,6 +36,7 @@
+ #include <libavformat/avformat.h>
+ #include <libavutil/imgutils.h>
+ #include <libswscale/swscale.h>
++#include <libavutil/version.h>
+
+ #ifdef __cplusplus
+ }
+@@ -186,7 +187,11 @@
+ AVFormatContext *pFormatCtx;
+ int videoStream;
+ AVCodecContext *pCodecCtx;
++#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(59, 0, 100)
+ AVCodec *pCodec;
++#else
++ const AVCodec *pCodec;
++#endif
+ AVFrame *pFrame;
+ AVFrame *pFrameOUT;
+ AVDictionary *optionsDict;