summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302018-01-28 21:57:43 +0100
committerM0Rf302018-01-28 21:57:43 +0100
commit79e03a8306f0d360fd9d417a3f552d2e4ec8e48c (patch)
tree513e95bc7de4ac51adf4eaa9fce5e23cd4a788d8
downloadaur-79e03a8306f0d360fd9d417a3f552d2e4ec8e48c.tar.gz
libindy: sdk based
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9161110ef97b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libindy
+ pkgdesc = Shared crypto library for Hyperledger Indy components
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/hyperledger/indy-crypto
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = rust
+ source = https://github.com/hyperledger/indy-sdk/archive/v1.3.0.tar.gz
+ md5sums = SKIP
+
+pkgname = libindy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a2cb6937324
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: robertfoster
+
+pkgname=libindy
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Shared crypto library for Hyperledger Indy components"
+arch=(i686 x86_64)
+url="https://github.com/hyperledger/indy-crypto"
+license=('APACHE')
+depends=('')
+makedepends=('rust')
+source=("https://github.com/hyperledger/indy-sdk/archive/v$pkgver.tar.gz")
+
+build() {
+ cd $srcdir/indy-sdk-$pkgver
+ cd libindy
+ cargo build --release
+}
+
+package() {
+ cd $srcdir/indy-sdk-$pkgver
+ cd libindy
+ install -Dm755 target/release/libindy.so "$pkgdir/usr/lib/libindy.so"
+ cp -r include $pkgdir/usr/include
+}
+
+md5sums=('SKIP')