summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302018-08-03 12:01:27 +0200
committerM0Rf302018-08-03 12:01:27 +0200
commita07c68518dc1ee4ace84cb742fcdb75b08cdc6e7 (patch)
treea23148ed78f7f96e46ab0c4eee22ef6367d1fa68
parent74782bf14064cc5681cf255a8e869b75ba830e3c (diff)
downloadaur-a07c68518dc1ee4ace84cb742fcdb75b08cdc6e7.tar.gz
libindy-crypto: 0.4.2
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ed6e69e7c2d..30309aba51d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: robertfoster
pkgname=libindy-crypto
-pkgver=0.1.6
+pkgver=0.4.2
pkgrel=1
pkgdesc="Shared crypto library for Hyperledger Indy components"
arch=(i686 x86_64)
@@ -9,20 +9,20 @@ url="https://github.com/hyperledger/indy-crypto"
license=('APACHE')
depends=('libsodium')
makedepends=('rust')
-source=("https://github.com/hyperledger/indy-crypto/archive/master.zip")
+source=("https://github.com/hyperledger/indy-crypto/archive/v$pkgver.tar.gz")
build() {
- cd $srcdir/indy-crypto-master
+ cd $srcdir/indy-crypto-$pkgver
cd $pkgname
cargo build --release
}
package() {
- cd $srcdir/indy-crypto-master
+ cd $srcdir/indy-crypto-$pkgver
cd $pkgname
install -Dm755 target/release/libindy_crypto.so "$pkgdir/usr/lib/libindy_crypto.so"
install -d 755 $pkgdir/usr/include/indy_crypto/
cp include/*.h $pkgdir/usr/include/indy_crypto
}
-md5sums=('SKIP')
+md5sums=('4d7aa0b77b7aea88f92fde5d01017afe')