summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302018-01-28 22:05:22 +0100
committerM0Rf302018-01-28 22:05:22 +0100
commitcc4772a8c4cf969387fdfadafe5f2240252701d6 (patch)
treeb9095e60197cc95f984b01f04fd02f8ed89726aa
parent55860bfe9a4b012fa3cb324ed7e1a1d18135b72c (diff)
downloadaur-cc4772a8c4cf969387fdfadafe5f2240252701d6.tar.gz
libindy-crypto: refactored
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6fdb21e77fa..1eca03219cf9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = libindy-crypto
pkgdesc = Shared crypto library for Hyperledger Indy components
- pkgver = 1.3.0
+ pkgver = 0.1.6
pkgrel = 1
url = https://github.com/hyperledger/indy-crypto
arch = i686
arch = x86_64
license = APACHE
makedepends = rust
- source = https://github.com/hyperledger/indy-sdk/archive/v1.3.0.tar.gz
+ source = https://github.com/hyperledger/indy-crypto/archive/master.zip
md5sums = SKIP
pkgname = libindy-crypto
diff --git a/PKGBUILD b/PKGBUILD
index 2ef8d6f73473..df10779f468b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: robertfoster
pkgname=libindy-crypto
-pkgver=1.3.0
+pkgver=0.1.6
pkgrel=1
pkgdesc="Shared crypto library for Hyperledger Indy components"
arch=(i686 x86_64)
@@ -9,18 +9,18 @@ url="https://github.com/hyperledger/indy-crypto"
license=('APACHE')
depends=('')
makedepends=('rust')
-source=("https://github.com/hyperledger/indy-sdk/archive/v$pkgver.tar.gz")
+source=("https://github.com/hyperledger/indy-crypto/archive/master.zip")
build() {
- cd $srcdir/indy-sdk-$pkgver
- cd libindy
+ cd $srcdir/indy-crypto-master
+ cd $pkgname
cargo build --release
}
package() {
- cd $srcdir/indy-sdk-$pkgver
- cd libindy
- install -Dm755 target/release/libindy.so "$pkgdir/usr/lib/libindy.so"
+ cd $srcdir/indy-crypto-master
+ cd $pkgname
+ install -Dm755 target/release/libindy_crypto.so "$pkgdir/usr/lib/libindy_crypto.so"
cp -r include $pkgdir/usr/include
}