summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302018-01-28 20:23:31 +0100
committerM0Rf302018-01-28 20:23:31 +0100
commitf36858895ff23d5085f262f346cfd42460ea07d6 (patch)
treeb9095e60197cc95f984b01f04fd02f8ed89726aa
downloadaur-f36858895ff23d5085f262f346cfd42460ea07d6.tar.gz
libindy-crypto: first commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1eca03219cf9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libindy-crypto
+ pkgdesc = Shared crypto library for Hyperledger Indy components
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = https://github.com/hyperledger/indy-crypto
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = rust
+ source = https://github.com/hyperledger/indy-crypto/archive/master.zip
+ md5sums = SKIP
+
+pkgname = libindy-crypto
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df10779f468b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: robertfoster
+
+pkgname=libindy-crypto
+pkgver=0.1.6
+pkgrel=1
+pkgdesc="Shared crypto library for Hyperledger Indy components"
+arch=(i686 x86_64)
+url="https://github.com/hyperledger/indy-crypto"
+license=('APACHE')
+depends=('')
+makedepends=('rust')
+source=("https://github.com/hyperledger/indy-crypto/archive/master.zip")
+
+build() {
+ cd $srcdir/indy-crypto-master
+ cd $pkgname
+ cargo build --release
+}
+
+package() {
+ cd $srcdir/indy-crypto-master
+ cd $pkgname
+ install -Dm755 target/release/libindy_crypto.so "$pkgdir/usr/lib/libindy_crypto.so"
+ cp -r include $pkgdir/usr/include
+}
+
+md5sums=('SKIP')