summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Teichroeb2015-06-08 16:34:00 -0700
committerJoel Teichroeb2015-06-08 16:34:00 -0700
commit5c61e46ca4872999d376b4dad6a63e672d5e34d3 (patch)
treeee20506ff54eff1b40627771f08c497d162eb885
downloadaur-5c61e46ca4872999d376b4dad6a63e672d5e34d3.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57d55fd95cd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libinput-git
+ pkgdesc = A library to handle input devices in Wayland compositors
+ pkgver = 0.17.0.r2.gbd4f129
+ pkgrel = 1
+ url = http://freedesktop.org/wiki/Software/libinput/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = mtdev
+ depends = systemd
+ depends = libevdev
+ provides = libinput=0.17.0.r2.gbd4f129
+ conflicts = libinput
+ source = git://anongit.freedesktop.org/wayland/libinput
+ sha1sums = SKIP
+
+pkgname = libinput-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1dc86324137
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Joel Teichroeb <joel@teichroeb.net>
+
+pkgname=libinput-git
+pkgver=0.17.0.r2.gbd4f129
+pkgrel=1
+pkgdesc='A library to handle input devices in Wayland compositors'
+arch=(i686 x86_64)
+url='http://freedesktop.org/wiki/Software/libinput/'
+provides=("libinput=${pkgver}")
+license=('MIT')
+depends=('mtdev' 'systemd' 'libevdev')
+makedepends=('git')
+conflicts=('libinput')
+source=(git://anongit.freedesktop.org/wayland/libinput)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd libinput
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd libinput
+
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd libinput
+ make DESTDIR="${pkgdir}" install
+}