summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbilabila2018-09-18 15:06:48 +0800
committerbilabila2018-09-18 15:06:48 +0800
commit02f998a3e4e90310fe184157cd6fa03e4cadbfd6 (patch)
treef89d62b06ce8c7f7574d09c8688f59eed54ba970
parent57ab41857f930ed27fe9fcc7d7f2afa678a15537 (diff)
downloadaur-02f998a3e4e90310fe184157cd6fa03e4cadbfd6.tar.gz
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--multiplier.patch10
3 files changed, 21 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5efbf16640ff..4e6dd0eedab9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,26 @@
pkgbase = libinput-multiplier
pkgdesc = scroll patch, discrete deltay multiplier
pkgver = 1.12.0
- pkgrel = 1
+ pkgrel = 2
url = http://freedesktop.org/wiki/Software/libinput/
arch = i686
arch = x86_64
license = MIT
- makedepends = meson
- makedepends = doxygen
- makedepends = graphviz
makedepends = gtk3
- makedepends = python-recommonmark
+ makedepends = meson
depends = mtdev
depends = systemd
depends = libevdev
depends = libwacom
+ optdepends = gtk3: libinput debug-gui
+ optdepends = python-pyudev: libinput measure
+ optdepends = python-evdev: libinput measure
provides = libinput=1.12.0
conflicts = libinput
- source = https://gitlab.freedesktop.org/libinput/libinput/-/archive/1.12.0/libinput-1.12.0.tar.gz
+ source = https://freedesktop.org/software/libinput/libinput-1.12.0.tar.xz
source = multiplier.patch
- md5sums = 5863fb1a6ed5131b2dd8c3bffe43c644
- md5sums = 71b3ecaf21c5ec18e0b82ff341da3fc7
- sha1sums = b773b0201c502f1f49b07769e396e13f7ae380dd
- sha1sums = 155b915b68867fe9ef610c47a3d79d5f1490ecb1
+ sha512sums = 4aee877785f9ac080e4f8ee20f3643bc4f3ddbc568aca6c363a962f8c8f76b8db7dc113c8167092f0277d112346a85b9a7e7c3c3f227ed243aaba32c9092c924
+ sha512sums = SKIP
pkgname = libinput-multiplier
diff --git a/PKGBUILD b/PKGBUILD
index cb595929e7c0..c6616bbca417 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,35 +3,36 @@ _pkgname=libinput
_patch=multiplier.patch
pkgname=$_pkgname-multiplier
pkgver=1.12.0
-pkgrel=1
+pkgrel=2
pkgdesc='scroll patch, discrete deltay multiplier'
arch=(i686 x86_64)
url='http://freedesktop.org/wiki/Software/libinput/'
provides=($_pkgname=$pkgver)
license=('MIT')
depends=('mtdev' 'systemd' 'libevdev' 'libwacom')
-makedepends=('meson' 'doxygen' 'graphviz' 'gtk3' 'python-recommonmark')
+makedepends=('gtk3' 'meson') # 'doxygen' 'graphviz' 'python-sphinx' 'python-recommonmark'
+optdepends=('gtk3: libinput debug-gui'
+ 'python-pyudev: libinput measure'
+ 'python-evdev: libinput measure')
conflicts=($_pkgname)
-source=(https://gitlab.freedesktop.org/$_pkgname/$_pkgname/-/archive/$pkgver/$_pkgname-$pkgver.tar.gz
+source=(https://freedesktop.org/software/$_pkgname/$_pkgname-$pkgver.tar.xz
$_patch)
-md5sums=(5863fb1a6ed5131b2dd8c3bffe43c644
- 71b3ecaf21c5ec18e0b82ff341da3fc7)
-sha1sums=(b773b0201c502f1f49b07769e396e13f7ae380dd
- 155b915b68867fe9ef610c47a3d79d5f1490ecb1)
+sha512sums=('4aee877785f9ac080e4f8ee20f3643bc4f3ddbc568aca6c363a962f8c8f76b8db7dc113c8167092f0277d112346a85b9a7e7c3c3f227ed243aaba32c9092c924'
+ 'SKIP')
prepare() {
cd "${srcdir}/$_pkgname-$pkgver"
- patch -p1 -i ../$_patch
+ patch -Np1 -i ../$_patch
}
build() {
cd "${srcdir}/$_pkgname-$pkgver"
meson build --prefix=/usr \
- --buildtype=release \
- -Dtests=false
- #--libexecdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ -Dtests=false \
+ -Ddocumentation=false
ninja -C build
}
package() {
cd "${srcdir}/$_pkgname-$pkgver"
DESTDIR="$pkgdir" ninja -C build install
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dvm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
diff --git a/multiplier.patch b/multiplier.patch
index 2171c1556cc5..4d5ff5aa8781 100644
--- a/multiplier.patch
+++ b/multiplier.patch
@@ -1,13 +1,3 @@
-diff --git a/.gitignore b/.gitignore
-index a4d1f1f6..af036939 100644
---- a/.gitignore
-+++ b/.gitignore
-@@ -10,3 +10,4 @@
- *.gcno
- tags
- *.gnuplot
-+/build/
-\ No newline at end of file
diff --git a/src/evdev.c b/src/evdev.c
index 7c6e921d..446a5cd6 100644
--- a/src/evdev.c