summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbilabila2023-08-26 11:25:31 +0800
committerbilabila2023-08-26 11:32:11 +0800
commit48b19b81eed54e7a5bb66ed8ee0495c773dfaab7 (patch)
treeedb9c6e0314819cca96870eda610e89a1d08aaea
parent42ac1dbe084a686ad158c84ac225da13f6600f6b (diff)
downloadaur-48b19b81eed54e7a5bb66ed8ee0495c773dfaab7.tar.gz
v1.24.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55015f624e4b..6f5d54aa8e2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libinput-multiplier
pkgdesc = libinput with scroll multiplier patch
- pkgver = 1.23.0
+ pkgver = 1.24.0
pkgrel = 1
url = http://freedesktop.org/wiki/Software/libinput
arch = x86_64
@@ -14,14 +14,16 @@ pkgbase = libinput-multiplier
depends = systemd
depends = libevdev
depends = libwacom
+ depends = systemd-libs
+ depends = glibc
optdepends = gtk4: libinput debug-gui
optdepends = python-pyudev: libinput measure
optdepends = python-libevdev: libinput measure
- provides = libinput=1.23.0
+ provides = libinput=1.24.0
conflicts = libinput
- source = https://gitlab.freedesktop.org/libinput/libinput/-/archive/1.23.0/libinput-1.23.0.tar.bz2
+ source = https://gitlab.freedesktop.org/libinput/libinput/-/archive/1.24.0/libinput-1.24.0.tar.bz2
source = multiplier.patch
- sha512sums = cb752d8611d70d9ea26d875aba9db8d0e319e60697aedef1b16295e8180761ce4c8c9635b1aaeb3cfc32d8c5fbe4abfd9a5a4fd29c4b964b25c853c90e816a43
+ sha512sums = 924554d62d232f99851db51386653e67083b8f3b8203b5d848294c08880e1ba153f80699900210d1b5b31566a2ef6bd4aa0662f107a2dcaed1fe0f7e1fb784db
sha512sums = c6a2793e592c69829e542c91aafc2de42c0eddec1f2570a465590584164a64d3828507f2f1194ec48f0f5d85aa624054c101287e981b2a82a3a43d85b426aa94
pkgname = libinput-multiplier
diff --git a/PKGBUILD b/PKGBUILD
index 34cb81cde73f..63e45d4a873c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=libinput
_patch=multiplier.patch
pkgname=$_pkgname-multiplier
-pkgver=1.23.0
+pkgver=1.24.0
pkgrel=1
pkgdesc='libinput with scroll multiplier patch'
arch=(x86_64)
@@ -10,7 +10,7 @@ url=http://freedesktop.org/wiki/Software/libinput
provides=($_pkgname=$pkgver)
conflicts=($_pkgname)
license=(custom)
-depends=(mtdev systemd libevdev libwacom)
+depends=(mtdev systemd libevdev libwacom systemd-libs glibc)
makedepends=(gtk4 meson wayland-protocols check)
checkdepends=('python-pytest')
optdepends=('gtk4: libinput debug-gui'
@@ -18,7 +18,7 @@ optdepends=('gtk4: libinput debug-gui'
'python-libevdev: libinput measure')
source=(https://gitlab.freedesktop.org/libinput/libinput/-/archive/$pkgver/$_pkgname-$pkgver.tar.bz2
$_patch)
-sha512sums=(cb752d8611d70d9ea26d875aba9db8d0e319e60697aedef1b16295e8180761ce4c8c9635b1aaeb3cfc32d8c5fbe4abfd9a5a4fd29c4b964b25c853c90e816a43
+sha512sums=(924554d62d232f99851db51386653e67083b8f3b8203b5d848294c08880e1ba153f80699900210d1b5b31566a2ef6bd4aa0662f107a2dcaed1fe0f7e1fb784db
c6a2793e592c69829e542c91aafc2de42c0eddec1f2570a465590584164a64d3828507f2f1194ec48f0f5d85aa624054c101287e981b2a82a3a43d85b426aa94)
prepare() {
cd "${srcdir}"/$_pkgname-$pkgver
@@ -28,6 +28,10 @@ build() {
arch-meson $_pkgname-$pkgver build \
-D udev-dir=/usr/lib/udev \
-D documentation=false
+
+ # Print config
+ # meson configure build
+
meson compile -C build
}
check() {