summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbilabila2019-04-17 14:15:46 +0800
committerbilabila2019-04-17 14:15:46 +0800
commitcc2bbce0f29f973038d2a8dcac1f7729bd0922ba (patch)
tree65348f31239d46c80b4c57e814c915f3900624c2
parente5bee399c83cb575ec3d5e5944cf8b916e14e3ed (diff)
downloadaur-cc2bbce0f29f973038d2a8dcac1f7729bd0922ba.tar.gz
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--multiplier.patch11
3 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45307af1df35..e53612f3d7a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = libinput-multiplier
pkgdesc = scroll patch, discrete deltay multiplier
- pkgver = 1.12.6
+ pkgver = 1.13.1
pkgrel = 1
- url = http://freedesktop.org/wiki/Software/libinput/
+ url = http://freedesktop.org/wiki/Software/libinput
arch = x86_64
- license = GPL
+ license = custom
makedepends = gtk3
makedepends = meson
depends = mtdev
@@ -14,12 +14,12 @@ pkgbase = libinput-multiplier
optdepends = gtk3: libinput debug-gui
optdepends = python-pyudev: libinput measure
optdepends = python-evdev: libinput measure
- provides = libinput=1.12.6
+ provides = libinput=1.13.1
conflicts = libinput
- source = https://freedesktop.org/software/libinput/libinput-1.12.6.tar.xz
+ source = https://freedesktop.org/software/libinput/libinput-1.13.1.tar.xz
source = multiplier.patch
- sha512sums = 02ad90c77a0c8c27fd96ec34e1546c5f0947ced49bad386372c1ef7c41b3b2157c39020f0766f20aaf2ab3c97128567e169279bea21115ced39499dda325d2ef
- sha512sums = 9564ccadac39632e09e574bee0910896bbc598d684fa0f3afa0414111b8064213290db9bf5b1106365a68555d11afd86e23fb8c957305448e6c4dd1df0743c93
+ sha512sums = a19deec802e704038df0901c103a82a3370f56e0299f4cc1b6aa84c1832a66fb638e6f9d0fa708b51df6c3b939cdc1271e4ff547c645c566be03dce0bc9ff7e0
+ sha512sums = c47b99a7d415f0560854d86aa445473bc6485a41a7062e9c12996d0b7bad146ea674e3488da620eefc9f3cc705be07c213b1b37a6df2ad0b215b3a3d617daa0d
pkgname = libinput-multiplier
diff --git a/PKGBUILD b/PKGBUILD
index ef9060b725b8..82dfbb0e7331 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,25 @@
_pkgname=libinput
_patch=multiplier.patch
pkgname=$_pkgname-multiplier
-pkgver=1.12.6
+pkgver=1.13.1
pkgrel=1
pkgdesc='scroll patch, discrete deltay multiplier'
arch=(x86_64)
-url='http://freedesktop.org/wiki/Software/libinput/'
+url=http://freedesktop.org/wiki/Software/libinput
provides=($_pkgname=$pkgver)
-license=('GPL')
-depends=('mtdev' 'systemd' 'libevdev' 'libwacom')
-makedepends=('gtk3' 'meson') # 'doxygen' 'graphviz' 'python-sphinx' 'python-recommonmark'
+conflicts=($_pkgname)
+license=(custom)
+depends=(mtdev systemd libevdev libwacom)
+makedepends=(gtk3 meson)
optdepends=('gtk3: libinput debug-gui'
'python-pyudev: libinput measure'
'python-evdev: libinput measure')
-conflicts=($_pkgname)
source=(https://freedesktop.org/software/$_pkgname/$_pkgname-$pkgver.tar.xz
$_patch)
-sha512sums=('02ad90c77a0c8c27fd96ec34e1546c5f0947ced49bad386372c1ef7c41b3b2157c39020f0766f20aaf2ab3c97128567e169279bea21115ced39499dda325d2ef'
- '9564ccadac39632e09e574bee0910896bbc598d684fa0f3afa0414111b8064213290db9bf5b1106365a68555d11afd86e23fb8c957305448e6c4dd1df0743c93')
+sha512sums=(a19deec802e704038df0901c103a82a3370f56e0299f4cc1b6aa84c1832a66fb638e6f9d0fa708b51df6c3b939cdc1271e4ff547c645c566be03dce0bc9ff7e0
+ d87fb912203c0c10f55b452b4cbb29abf86dbcb92a394029dc285fa53cba6b72446063cc3b3367b423cc5b5ff57526997272f321ea5b07a93a4532c1a9fea635)
prepare() {
- cd "${srcdir}/$_pkgname-$pkgver"
+ cd "${srcdir}"/$_pkgname-$pkgver
patch -Np1 -i ../$_patch
}
build() {
@@ -32,5 +32,5 @@ build() {
}
package() {
DESTDIR="$pkgdir" ninja -C build install
- install -Dvm644 $_pkgname-$pkgver/COPYING "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -Dvm644 $_pkgname-$pkgver/COPYING "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
}
diff --git a/multiplier.patch b/multiplier.patch
index 785b5beb1227..83fb9dd325c0 100644
--- a/multiplier.patch
+++ b/multiplier.patch
@@ -23,18 +23,17 @@ index 01f53974..2ee9e1dc 100644
#include "libinput.h"
#include "libinput-private.h"
-@@ -720,6 +722,16 @@ libinput_event_pointer_get_axis_value(struct libinput_event_pointer *event,
+@@ -720,6 +722,15 @@ libinput_event_pointer_get_axis_value(struct libinput_event_pointer *event,
return value;
}
-+static char *multiplier;
++static char *multiplier="1";
+static void libinput_discrete_deltay_multiplier(void) {
+ int fd;
+ char *file = "/tmp/libinput_discrete_deltay_multiplier";
-+ if ((fd = open(file, O_RDWR | O_CREAT, 0666)) == -1) exit(1);
-+ if (write(fd, "1", sizeof(char)) == -1) exit(1);
-+ if ((multiplier = mmap(NULL, 1024, PROT_READ, MAP_SHARED, fd, 0)) ==
-+ MAP_FAILED) exit(1);
++ if ((fd = open(file, O_RDWR | O_CREAT, 0666)) == -1) return;
++ if (write(fd, "1", sizeof(char)) == -1) return;
++ multiplier = mmap(NULL, 1024, PROT_READ, MAP_SHARED, fd, 0);
+}
+
LIBINPUT_EXPORT double