aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Vincent2017-04-03 16:30:11 +0100
committerTom Vincent2017-04-03 16:30:34 +0100
commit30a30daa9775fd99669fd01c56b8830b9cb435ed (patch)
tree511fb4939e66075c78b3207edd5e642543671cce
downloadaur-30a30daa9775fd99669fd01c56b8830b9cb435ed.tar.gz
Initial commit
Based off ABS extra/libinput. Relevant upstream issues: https://bugs.freedesktop.org/show_bug.cgi?id=94379 https://bugs.freedesktop.org/show_bug.cgi?id=98839 https://cgit.freedesktop.org/wayland/libinput/commit/?id=48473994c8e60189356feae7b7eae25288e5ac28
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD50
-rw-r--r--disable-hysteresis.patch19
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2ab4d83ad65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = libinput-no-hysteresis
+ pkgdesc = Input device management and event handling library sans hysteresis
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = https://www.freedesktop.org/wiki/Software/libinput/
+ arch = i686
+ arch = x86_64
+ license = custom:X11
+ makedepends = doxygen
+ makedepends = graphviz
+ makedepends = gtk3
+ depends = mtdev
+ depends = systemd
+ depends = libevdev
+ depends = libwacom
+ provides = libinput=1.7.0
+ conflicts = libinput
+ source = https://freedesktop.org/software/libinput/libinput-1.7.0.tar.xz
+ source = https://freedesktop.org/software/libinput/libinput-1.7.0.tar.xz.sig
+ source = disable-hysteresis.patch
+ validpgpkeys = 3C2C43D9447D5938EF4551EBE23B7E70B467F0BF
+ sha512sums = 9058eab813ea3de230835155ca843f248127cbafaf1aecc9a2e209a0215b090beef0468cc863a24320f8d0db1f2863baba680e2416e9e409e958b2c1d18e43a1
+ sha512sums = SKIP
+ sha512sums = 22c97898b8bd2ed6757ce2a0f2c19d8ff908b3134a9bd435285bc5c59d9d4a17cc5bb4ef0bfb01001ef9aeb2c917bdcc79324cc68bc442c2038d9c448773ac5e
+
+pkgname = libinput-no-hysteresis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7356569ab10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Tom Vincent <aur@tlvince.com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Jan de Groot
+
+pkgname=libinput-no-hysteresis
+_pkgname=libinput
+pkgver=1.7.0
+pkgrel=1
+pkgdesc="Input device management and event handling library sans hysteresis"
+arch=(i686 x86_64)
+url="https://www.freedesktop.org/wiki/Software/libinput/"
+provides=("libinput=${pkgver}")
+license=(custom:X11)
+depends=('mtdev' 'systemd' 'libevdev' 'libwacom')
+# currently no doc files to install
+makedepends=('doxygen' 'graphviz' 'gtk3')
+#checkdepends=('check' 'libunwind')
+conflicts=('libinput')
+source=(https://freedesktop.org/software/$_pkgname/$_pkgname-$pkgver.tar.xz{,.sig} disable-hysteresis.patch)
+sha512sums=('9058eab813ea3de230835155ca843f248127cbafaf1aecc9a2e209a0215b090beef0468cc863a24320f8d0db1f2863baba680e2416e9e409e958b2c1d18e43a1'
+ 'SKIP'
+ '22c97898b8bd2ed6757ce2a0f2c19d8ff908b3134a9bd435285bc5c59d9d4a17cc5bb4ef0bfb01001ef9aeb2c917bdcc79324cc68bc442c2038d9c448773ac5e')
+validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
+
+prepare() {
+ cd $_pkgname-$pkgver
+ patch -p1 -i "${srcdir}/disable-hysteresis.patch"
+}
+
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+check() {
+ cd $_pkgname-$pkgver
+# disabled for now:
+# https://github.com/libcheck/check/issues/18
+# make check
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${_pkgname}/COPYING"
+ # install doc - no Makefile target
+ install -v -dm755 ${pkgdir}/usr/share/doc/libinput
+ cp -rv doc/html/* ${pkgdir}/usr/share/doc/libinput
+}
diff --git a/disable-hysteresis.patch b/disable-hysteresis.patch
new file mode 100644
index 000000000000..203ed4e0a371
--- /dev/null
+++ b/disable-hysteresis.patch
@@ -0,0 +1,19 @@
+diff --git src/evdev-mt-touchpad.c src/evdev-mt-touchpad.c
+index 4a8b618..6cef479 100644
+--- a/src/evdev-mt-touchpad.c
++++ b/src/evdev-mt-touchpad.c
+@@ -2351,12 +2351,8 @@ tp_init_default_resolution(struct tp_dispatch *tp,
+ static inline void
+ tp_init_hysteresis(struct tp_dispatch *tp)
+ {
+- int res_x, res_y;
+-
+- res_x = tp->device->abs.absinfo_x->resolution;
+- res_y = tp->device->abs.absinfo_y->resolution;
+- tp->hysteresis_margin.x = res_x/2;
+- tp->hysteresis_margin.y = res_y/2;
++ tp->hysteresis_margin.x = 0;
++ tp->hysteresis_margin.y = 0;
+ }
+
+ static void