aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Vincent2018-07-25 23:32:11 +0100
committerTom Vincent2018-07-25 23:32:11 +0100
commit7267e0d9fbaff0bccb5017f09ae3ad18320b0308 (patch)
treefdd618bd69d8208ccc8f543d0b123d97541543a0
parent7f227cfadfe0a3e66136e06b07596e99aada5a35 (diff)
downloadaur-7267e0d9fbaff0bccb5017f09ae3ad18320b0308.tar.gz
v1.11.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD6
-rw-r--r--disable-hysteresis.patch27
3 files changed, 23 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29eca26702af..72ed5fd92a91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libinput-no-hysteresis
pkgdesc = Input device management and event handling library sans hysteresis
- pkgver = 1.10.3
+ pkgver = 1.11.2
pkgrel = 1
url = https://www.freedesktop.org/wiki/Software/libinput/
arch = x86_64
@@ -16,15 +16,15 @@ pkgbase = libinput-no-hysteresis
optdepends = gtk3: libinput debug-gui
optdepends = python-pyudev: libinput measure
optdepends = python-evdev: libinput measure
- provides = libinput=1.10.3
- conflicts = libinput=1.10.3
- source = https://freedesktop.org/software/libinput/libinput-1.10.3.tar.xz
- source = https://freedesktop.org/software/libinput/libinput-1.10.3.tar.xz.sig
+ provides = libinput=1.11.2
+ conflicts = libinput=1.11.2
+ source = https://freedesktop.org/software/libinput/libinput-1.11.2.tar.xz
+ source = https://freedesktop.org/software/libinput/libinput-1.11.2.tar.xz.sig
source = disable-hysteresis.patch
validpgpkeys = 3C2C43D9447D5938EF4551EBE23B7E70B467F0BF
- sha512sums = 4c73673e138a7aff9d6f2d189b8afdfb51c868eca0487c8c487ffd3bb48849994a9095fbd4c5c725ee17fafc2a85298106e0cc7b59b4a8cd13ec28f65d15c01d
+ sha512sums = cb6ada877fc3c09f634f3db39d5507e66d4b86c3d632bb8f7498c7b01fdf8372b2053a79b641293900b7fcc0aa4e920f7c830d9c7b2d9ff3cd61c58eb7c20b65
sha512sums = SKIP
- sha512sums = 67fa2e8efd982f2fa32ceec2dbf29e95288e7a68e7a229831d8d59829b09a0ab8eba500696d1b37d755a8138e054c429c7fadfa92ecdbac7925f331643443c41
+ sha512sums = 2217ec9b6b9a7843cec564eeae22e0f5f5ddacd946cc863735f43fe2a2b264e155b72aa1cf3d39f567a4c5007371d38c98c606751c3c32b7d6a132d5dfc2d52b
pkgname = libinput-no-hysteresis
diff --git a/PKGBUILD b/PKGBUILD
index 3b2be8da5727..0364be0c21b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=libinput-no-hysteresis
_pkgname=libinput
-pkgver=1.10.3
+pkgver=1.11.2
pkgrel=1
pkgdesc="Input device management and event handling library sans hysteresis"
url="https://www.freedesktop.org/wiki/Software/libinput/"
@@ -19,9 +19,9 @@ optdepends=('gtk3: libinput debug-gui'
'python-evdev: libinput measure')
source=(https://freedesktop.org/software/$_pkgname/$_pkgname-$pkgver.tar.xz{,.sig}
disable-hysteresis.patch)
-sha512sums=('4c73673e138a7aff9d6f2d189b8afdfb51c868eca0487c8c487ffd3bb48849994a9095fbd4c5c725ee17fafc2a85298106e0cc7b59b4a8cd13ec28f65d15c01d'
+sha512sums=('cb6ada877fc3c09f634f3db39d5507e66d4b86c3d632bb8f7498c7b01fdf8372b2053a79b641293900b7fcc0aa4e920f7c830d9c7b2d9ff3cd61c58eb7c20b65'
'SKIP'
- '67fa2e8efd982f2fa32ceec2dbf29e95288e7a68e7a229831d8d59829b09a0ab8eba500696d1b37d755a8138e054c429c7fadfa92ecdbac7925f331643443c41')
+ '2217ec9b6b9a7843cec564eeae22e0f5f5ddacd946cc863735f43fe2a2b264e155b72aa1cf3d39f567a4c5007371d38c98c606751c3c32b7d6a132d5dfc2d52b')
validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
prepare() {
diff --git a/disable-hysteresis.patch b/disable-hysteresis.patch
index da8aaa667052..19e5deefda6c 100644
--- a/disable-hysteresis.patch
+++ b/disable-hysteresis.patch
@@ -1,16 +1,15 @@
---- a/src/evdev-mt-touchpad.c 2018-04-08 19:11:22.549800840 +0100
-+++ b/src/evdev-mt-touchpad.c 2018-04-08 19:11:45.022773612 +0100
-@@ -3022,12 +3022,8 @@
- static inline void
- tp_init_hysteresis(struct tp_dispatch *tp)
- {
-- int res_x, res_y;
--
-- res_x = tp->device->abs.absinfo_x->resolution;
-- res_y = tp->device->abs.absinfo_y->resolution;
-- tp->hysteresis.margin.x = res_x/2;
-- tp->hysteresis.margin.y = res_y/2;
+--- a/src/evdev-mt-touchpad.c 2018-07-25 23:27:12.719986275 +0100
++++ b/src/evdev-mt-touchpad.c 2018-07-25 23:27:24.227122395 +0100
+@@ -3190,9 +3190,9 @@
+ else
+ ymargin = ay->resolution/4;
+
+- tp->hysteresis.margin.x = xmargin;
+- tp->hysteresis.margin.y = ymargin;
+- tp->hysteresis.enabled = (ax->fuzz || ay->fuzz);
+ tp->hysteresis.margin.x = 0;
+ tp->hysteresis.margin.y = 0;
- tp->hysteresis.enabled = false;
- }
++ tp->hysteresis.enabled = false;
+ if (tp->hysteresis.enabled)
+ evdev_log_debug(tp->device,
+ "hysteresis enabled. "