aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Vincent2018-04-08 19:15:12 +0100
committerTom Vincent2018-04-08 19:15:12 +0100
commit7f227cfadfe0a3e66136e06b07596e99aada5a35 (patch)
treefd054b34e42dc1300ee60eb43ac7d54c8bc13acd
parent66c132ec6e5ec3497d4ac92807d238e0493e1335 (diff)
downloadaur-7f227cfadfe0a3e66136e06b07596e99aada5a35.tar.gz
v1.10.3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD7
-rw-r--r--disable-hysteresis.patch19
3 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ec23bc456c0..29eca26702af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libinput-no-hysteresis
pkgdesc = Input device management and event handling library sans hysteresis
- pkgver = 1.9.4
+ pkgver = 1.10.3
pkgrel = 1
url = https://www.freedesktop.org/wiki/Software/libinput/
arch = x86_64
@@ -16,14 +16,15 @@ pkgbase = libinput-no-hysteresis
optdepends = gtk3: libinput debug-gui
optdepends = python-pyudev: libinput measure
optdepends = python-evdev: libinput measure
- provides = libinput=1.9.4
- source = https://freedesktop.org/software/libinput/libinput-1.9.4.tar.xz
- source = https://freedesktop.org/software/libinput/libinput-1.9.4.tar.xz.sig
+ provides = libinput=1.10.3
+ conflicts = libinput=1.10.3
+ source = https://freedesktop.org/software/libinput/libinput-1.10.3.tar.xz
+ source = https://freedesktop.org/software/libinput/libinput-1.10.3.tar.xz.sig
source = disable-hysteresis.patch
validpgpkeys = 3C2C43D9447D5938EF4551EBE23B7E70B467F0BF
- sha512sums = 302f9497ea9ffb2163c643e9ca2f0a773ea141f6fe0a3aa3d8e86eb11a5d11e75d858b1e679ebfd3f913c645beac059cfd356b37c4ea17a8853068f79a740a4b
+ sha512sums = 4c73673e138a7aff9d6f2d189b8afdfb51c868eca0487c8c487ffd3bb48849994a9095fbd4c5c725ee17fafc2a85298106e0cc7b59b4a8cd13ec28f65d15c01d
sha512sums = SKIP
- sha512sums = 22c97898b8bd2ed6757ce2a0f2c19d8ff908b3134a9bd435285bc5c59d9d4a17cc5bb4ef0bfb01001ef9aeb2c917bdcc79324cc68bc442c2038d9c448773ac5e
+ sha512sums = 67fa2e8efd982f2fa32ceec2dbf29e95288e7a68e7a229831d8d59829b09a0ab8eba500696d1b37d755a8138e054c429c7fadfa92ecdbac7925f331643443c41
pkgname = libinput-no-hysteresis
diff --git a/PKGBUILD b/PKGBUILD
index d7d4c7541e4d..3b2be8da5727 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@
pkgname=libinput-no-hysteresis
_pkgname=libinput
-pkgver=1.9.4
+pkgver=1.10.3
pkgrel=1
pkgdesc="Input device management and event handling library sans hysteresis"
url="https://www.freedesktop.org/wiki/Software/libinput/"
arch=(x86_64)
license=(custom:X11)
provides=("libinput=${pkgver}")
+conflicts=("libinput=${pkgver}")
depends=('mtdev' 'systemd' 'libevdev' 'libwacom')
makedepends=('doxygen' 'graphviz' 'gtk3' 'meson')
optdepends=('gtk3: libinput debug-gui'
@@ -18,9 +19,9 @@ optdepends=('gtk3: libinput debug-gui'
'python-evdev: libinput measure')
source=(https://freedesktop.org/software/$_pkgname/$_pkgname-$pkgver.tar.xz{,.sig}
disable-hysteresis.patch)
-sha512sums=('302f9497ea9ffb2163c643e9ca2f0a773ea141f6fe0a3aa3d8e86eb11a5d11e75d858b1e679ebfd3f913c645beac059cfd356b37c4ea17a8853068f79a740a4b'
+sha512sums=('4c73673e138a7aff9d6f2d189b8afdfb51c868eca0487c8c487ffd3bb48849994a9095fbd4c5c725ee17fafc2a85298106e0cc7b59b4a8cd13ec28f65d15c01d'
'SKIP'
- '22c97898b8bd2ed6757ce2a0f2c19d8ff908b3134a9bd435285bc5c59d9d4a17cc5bb4ef0bfb01001ef9aeb2c917bdcc79324cc68bc442c2038d9c448773ac5e')
+ '67fa2e8efd982f2fa32ceec2dbf29e95288e7a68e7a229831d8d59829b09a0ab8eba500696d1b37d755a8138e054c429c7fadfa92ecdbac7925f331643443c41')
validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
prepare() {
diff --git a/disable-hysteresis.patch b/disable-hysteresis.patch
index 203ed4e0a371..da8aaa667052 100644
--- a/disable-hysteresis.patch
+++ b/disable-hysteresis.patch
@@ -1,8 +1,6 @@
-diff --git src/evdev-mt-touchpad.c src/evdev-mt-touchpad.c
-index 4a8b618..6cef479 100644
---- a/src/evdev-mt-touchpad.c
-+++ b/src/evdev-mt-touchpad.c
-@@ -2351,12 +2351,8 @@ tp_init_default_resolution(struct tp_dispatch *tp,
+--- a/src/evdev-mt-touchpad.c 2018-04-08 19:11:22.549800840 +0100
++++ b/src/evdev-mt-touchpad.c 2018-04-08 19:11:45.022773612 +0100
+@@ -3022,12 +3022,8 @@
static inline void
tp_init_hysteresis(struct tp_dispatch *tp)
{
@@ -10,10 +8,9 @@ index 4a8b618..6cef479 100644
-
- res_x = tp->device->abs.absinfo_x->resolution;
- res_y = tp->device->abs.absinfo_y->resolution;
-- tp->hysteresis_margin.x = res_x/2;
-- tp->hysteresis_margin.y = res_y/2;
-+ tp->hysteresis_margin.x = 0;
-+ tp->hysteresis_margin.y = 0;
+- tp->hysteresis.margin.x = res_x/2;
+- tp->hysteresis.margin.y = res_y/2;
++ tp->hysteresis.margin.x = 0;
++ tp->hysteresis.margin.y = 0;
+ tp->hysteresis.enabled = false;
}
-
- static void