summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorParker Reed2019-11-05 18:55:05 -0500
committerParker Reed2019-11-05 18:55:05 -0500
commitad7ee5b5acb9f69c09c5fe2d1e75d67ffec257fe (patch)
tree5667e57dcd4ce8a186edc116a832abb0a64ad3fa
parenteadfe2dd846aebf434445b3f58433af19d46af84 (diff)
downloadaur-ad7ee5b5acb9f69c09c5fe2d1e75d67ffec257fe.tar.gz
Create patch and move to prepare
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--libinput-nomiddletap.patch11
3 files changed, 23 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9ab82aed708..aafb4ae515db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libinput-nomiddletap
pkgdesc = Input device management and event handling library (With middle button tap disabled)
pkgver = 1.14.3
- pkgrel = 1
+ pkgrel = 2
url = https://www.freedesktop.org/wiki/Software/libinput/
arch = x86_64
license = custom:X11
@@ -18,9 +18,11 @@ pkgbase = libinput-nomiddletap
conflicts = libinput
source = https://freedesktop.org/software/libinput/libinput-1.14.3.tar.xz
source = https://freedesktop.org/software/libinput/libinput-1.14.3.tar.xz.sig
+ source = libinput-nomiddletap.patch
validpgpkeys = 3C2C43D9447D5938EF4551EBE23B7E70B467F0BF
sha512sums = f01d1bd1b25b8060519575644597d35f0c89de5386d298441f440128ceee3e57549921a058adec31adc8b33dbdedf4c0bd12c76905a69f752859d3136e26336d
sha512sums = SKIP
+ sha512sums = 4c95709c27794969459e31f8b0e71047e3c6b4fbd7ca6d9c2bac08b2c4dd1d25e44609175f1764e55e03c8e1510af8b712df3ee9879ec8b38e628ab0df540186
pkgname = libinput-nomiddletap
diff --git a/PKGBUILD b/PKGBUILD
index 93963b0f6cf5..86430eb56960 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=libinput-nomiddletap
_basename=libinput
pkgver=1.14.3
-pkgrel=1
+pkgrel=2
pkgdesc="Input device management and event handling library (With middle button tap disabled)"
url="https://www.freedesktop.org/wiki/Software/libinput/"
arch=(x86_64)
@@ -16,13 +16,18 @@ optdepends=('gtk3: libinput debug-gui'
'python-libevdev: libinput measure')
provides=('libinput=${pkgver}')
conflicts=('libinput')
-source=(https://freedesktop.org/software/$_basename/$_basename-$pkgver.tar.xz{,.sig})
+source=(https://freedesktop.org/software/$_basename/$_basename-$pkgver.tar.xz{,.sig}
+ 'libinput-nomiddletap.patch')
sha512sums=('f01d1bd1b25b8060519575644597d35f0c89de5386d298441f440128ceee3e57549921a058adec31adc8b33dbdedf4c0bd12c76905a69f752859d3136e26336d'
- 'SKIP')
+ 'SKIP'
+ '4c95709c27794969459e31f8b0e71047e3c6b4fbd7ca6d9c2bac08b2c4dd1d25e44609175f1764e55e03c8e1510af8b712df3ee9879ec8b38e628ab0df540186')
validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
+prepare() {
+ patch -p1 < libinput-nomiddletap.patch
+}
+
build() {
- sed 's/BTN_LEFT\, BTN_RIGHT\, BTN_MIDDLE/BTN_LEFT\, BTN_RIGHT/g' -i $_basename-$pkgver/src/evdev-mt-touchpad-tap.c
arch-meson $_basename-$pkgver build \
-Dudev-dir=/usr/lib/udev \
-Dtests=false \
diff --git a/libinput-nomiddletap.patch b/libinput-nomiddletap.patch
new file mode 100644
index 000000000000..6820a0c71d56
--- /dev/null
+++ b/libinput-nomiddletap.patch
@@ -0,0 +1,11 @@
+--- ./libinput-1.14.3/src/evdev-mt-touchpad-tap.c 2019-11-05 18:44:22.855147128 -0500
++++ ./libinput-1.14.3/src/evdev-mt-touchpad-tap.c 2019-11-05 18:44:53.341613562 -0500
+@@ -119,7 +119,7 @@
+ {
+ int32_t button;
+ int32_t button_map[2][3] = {
+- { BTN_LEFT, BTN_RIGHT, BTN_MIDDLE },
++ { BTN_LEFT, BTN_RIGHT },
+ { BTN_LEFT, BTN_MIDDLE, BTN_RIGHT },
+ };
+