summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2019-09-23 12:45:06 +0530
committerlibrewish2019-09-23 12:45:06 +0530
commit669c2bf9c4c939a765212133d3591af3cd9d1c87 (patch)
treef976abd92873ff219aa22b236e1052089ed04052
downloadaur-669c2bf9c4c939a765212133d3591af3cd9d1c87.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..031ba33209b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libinput_gestures_qt
+ pkgdesc = qt-based gui app for libinput-gestures
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/OneAdder/libinput_gestures_qt
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = libinput-gestures
+ depends = python-pyqt5
+ source = libinput_gestures_qt-0.4.tar.gz::https://github.com/OneAdder/libinput_gestures_qt/archive/v.0.4.tar.gz
+ sha256sums = 7f7e0a65c506b917ffccbe9586e3b6dcd24ce536c382d43105eb436958476cbd
+
+pkgname = libinput_gestures_qt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01c6b0c8c96f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+
+pkgname=libinput_gestures_qt
+pkgver=0.4
+pkgrel=1
+pkgdesc="qt-based gui app for libinput-gestures"
+arch=('any')
+url="https://github.com/OneAdder/libinput_gestures_qt"
+license=('GPL3')
+depends=('libinput-gestures' 'python-pyqt5')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/OneAdder/libinput_gestures_qt/archive/v.$pkgver.tar.gz")
+sha256sums=('7f7e0a65c506b917ffccbe9586e3b6dcd24ce536c382d43105eb436958476cbd')
+
+build() {
+ cd "$pkgname-v.$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-v.$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}