summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraoleynichenko2017-01-23 18:49:53 +0000
committeraoleynichenko2017-01-23 18:49:53 +0000
commit729cab26460f363e74d970dbe805f09aee900d64 (patch)
tree564b3aa333ef8d0e101a373b30a4b09f2626bbc7
downloadaur-729cab26460f363e74d970dbe805f09aee900d64.tar.gz
tools for computational quantum chemistry - high-performance library for evaluation of molecular integrals over gaussian basis functions
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD46
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..467c0f1d0590
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libint2
+ pkgdesc = A high-performance library for evaluation of molecular integrals of many-body operators over Gaussian functions
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = https://github.com/evaleev/libint
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ makedepends = automake
+ makedepends = autoconf
+ source = https://github.com/evaleev/libint/archive/master.zip
+ md5sums = SKIP
+
+pkgname = libint2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5949a1814c2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Alexander Oleynichenko <alexvoleynichenko@gmail.com>
+pkgname=libint2
+pkgver='2.3.0'
+pkgrel=1
+epoch=
+pkgdesc="A high-performance library for evaluation of molecular integrals of many-body operators over Gaussian functions"
+arch=('i686' 'x86_64')
+url="https://github.com/evaleev/libint"
+license=('GPL')
+groups=()
+depends=()
+makedepends=(gcc automake autoconf)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/evaleev/libint/archive/master.zip")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd "$srcdir/libint-master"
+ ./autogen.sh
+ mkdir build
+ cd build
+ ../configure --prefix=/usr
+ make -j8
+}
+
+check() {
+ cd "$srcdir/libint-master/build"
+# You may uncomment 'make check' line if you want;
+# however, check is a VERY time-consuming and actually not needed
+# make -k check
+}
+
+package() {
+ cd "$srcdir/libint-master/build"
+ make DESTDIR="$pkgdir/" install
+}