summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Landauer2016-11-29 21:03:37 +0100
committerBernhard Landauer2016-11-29 21:03:37 +0100
commit07c335df07302c750286fc99297eac3c7a385c82 (patch)
tree1d5f89acfffbd208403be294232068fa1f4970a5
parent1e1f7ab98b91019c0f893b8c0548a3dd3d855df9 (diff)
downloadaur-07c335df07302c750286fc99297eac3c7a385c82.tar.gz
update to 1.2.0.r41, use github source
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD59
-rw-r--r--SSLv23.patch12
3 files changed, 34 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2328446e44b5..5c6fd719d611 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,27 @@
# Generated by mksrcinfo v8
-# Mon Mar 14 22:35:52 UTC 2016
+# Tue Nov 29 19:58:42 UTC 2016
pkgbase = libiphone-git
- pkgdesc = libiphone is a software library that talks the native Apple USB protocols that the iPhone uses. (no cython support for now)
- pkgver = 1.2.0.r13.gdf1f5c4
+ pkgdesc = libimobiledevice is a software library that talks the protocols to support iPhone and iPod Touch devices on Linux
+ pkgver = 1.2.0.r41.ga1c7285
pkgrel = 1
- url = http://libimobiledevice.org/
+ url = http://www.libimobiledevice.org/
arch = i686
arch = x86_64
- license = GPL
- makedepends = autoconf
- makedepends = automake
- makedepends = gcc
+ license = GPL2
+ license = LGPL2.1
makedepends = git
- makedepends = make
- makedepends = pkgconfig
depends = gnutls
+ depends = openssl
depends = libplist
- depends = libusb
- depends = usbmuxd
+ depends = libusbmuxd
+ optdepends = cython: Python bindings
optdepends = doxygen: Documentation
provides = libiphone
- source = libiphone::git+http://git.sukimashita.com/libimobiledevice.git
- source = SSLv23.patch
- md5sums = SKIP
- md5sums = 1cf25e39d353e02c7c8daaa41bd671e9
+ provides = libimobiledevice
+ conflicts = libiphone
+ conflicts = libimobiledevice
+ source = git+https://github.com/libimobiledevice/libimobiledevice.git
+ sha512sums = SKIP
pkgname = libiphone-git
diff --git a/PKGBUILD b/PKGBUILD
index 8a79c186e0e4..3a383b678526 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,37 @@
# Maintainer: Bernhard Landauer <oberon@manjaro.org>
-# Maintainer: Richard Schwab <mail NOSPAM w.tf-w.tf>
+# Contributor: Nikias Bassen
+# Contributor: Martin Szulecki
pkgname=libiphone-git
-pkgver=1.2.0.r13.gdf1f5c4
+_pkgname=libimobiledevice
+pkgver=1.2.0.r41.ga1c7285
pkgrel=1
-pkgdesc="libiphone is a software library that talks the native Apple USB protocols that the iPhone uses. (no cython support for now)"
-url="http://libimobiledevice.org/"
+pkgdesc="libimobiledevice is a software library that talks the protocols to support iPhone and iPod Touch devices on Linux"
+url="http://www.libimobiledevice.org/"
arch=('i686' 'x86_64')
-license=('GPL')
-depends=('gnutls'
-# 'fuse'
-# 'glib2'
- 'libplist'
- 'libusb'
-# 'libxml2'
-# 'libxml++'
- 'usbmuxd')
-makedepends=('autoconf'
- 'automake'
- 'gcc'
- 'git'
- 'make'
- 'pkgconfig')
-optdepends=('doxygen: Documentation')
-provides=('libiphone')
-source=('libiphone::git+http://git.sukimashita.com/libimobiledevice.git'
- 'SSLv23.patch')
-md5sums=('SKIP'
- '1cf25e39d353e02c7c8daaa41bd671e9')
+license=('GPL2' 'LGPL2.1')
+depends=('gnutls' 'openssl' 'libplist' 'libusbmuxd')
+optdepends=('cython: Python bindings'
+ 'doxygen: Documentation')
+makedepends=('git')
+provides=('libiphone' "$_pkgname")
+conflicts=('libiphone' "$_pkgname")
-prepare() {
- cd libiphone
- patch -p1 < ../SSLv23.patch
-}
+source=("git+https://github.com/$_pkgname/$_pkgname.git")
+sha512sums=('SKIP')
pkgver() {
- cd libiphone
+ cd $_pkgname
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd libiphone
-
- msg "Configuring..."
-
- ./autogen.sh --prefix=/usr --without-cython
-
- msg "Starting make..."
+ cd $_pkgname
+ PYTHON=/usr/bin/python2 ./autogen.sh --prefix=/usr
make
}
package() {
- cd libiphone
- make DESTDIR=${pkgdir} install
+ cd $_pkgname
+ make DESTDIR="$pkgdir" install
}
diff --git a/SSLv23.patch b/SSLv23.patch
deleted file mode 100644
index 2811e5ab7d7b..000000000000
--- a/SSLv23.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rupN libiphone.orig/src/idevice.c libiphone/src/idevice.c
---- libiphone.orig/src/idevice.c 2016-03-14 23:30:17.705117000 +0100
-+++ libiphone/src/idevice.c 2016-03-14 23:33:39.937235698 +0100
-@@ -678,7 +678,7 @@ LIBIMOBILEDEVICE_API idevice_error_t ide
- }
- BIO_set_fd(ssl_bio, (int)(long)connection->data, BIO_NOCLOSE);
-
-- SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv3_method());
-+ SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv23_method());
- if (ssl_ctx == NULL) {
- debug_info("ERROR: Could not create SSL context.");
- BIO_free(ssl_bio);