summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x9fff002020-06-20 19:23:56 +0200
committer0x9fff002020-06-20 19:23:56 +0200
commit10f603dbb0b11ef65df9e3913d84e7edb5f29563 (patch)
tree40aa55374302bea85789b819f4ceb10d35e47f48
downloadaur-10f603dbb0b11ef65df9e3913d84e7edb5f29563.tar.gz
1.0.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore27
-rw-r--r--.gitignore_append1
-rw-r--r--PKGBUILD27
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8755e3fe69fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libirecovery
+ pkgdesc = Library and utility to talk to iBoot/iBSS via USB
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://www.libimobiledevice.org/
+ arch = x86_64
+ license = LGPL2.1
+ depends = libusb
+ depends = readline
+ source = https://www.libimobiledevice.org/downloads/libirecovery-1.0.0.tar.bz2
+ sha256sums = cda0aba10a5b6fc2e1d83946b009e3e64d0be36912a986e35ad6d34b504ad9b4
+
+pkgname = libirecovery
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f12030797c07
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+# archlinuxpackages linux
diff --git a/.gitignore_append b/.gitignore_append
new file mode 100644
index 000000000000..a92184e5a9bf
--- /dev/null
+++ b/.gitignore_append
@@ -0,0 +1 @@
+# archlinuxpackages linux
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..247634ab307a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: 0x9fff00 <0x9fff00+git@protonmail.ch>
+# Contributor: Ivan Shapovalov <intelfx@intelfx.name>
+# Contributor: Matthew Bauer <mjbauer95@gmail.com>
+
+pkgname=libirecovery
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Library and utility to talk to iBoot/iBSS via USB"
+arch=('x86_64')
+url="https://www.libimobiledevice.org/"
+license=('LGPL2.1')
+depends=('libusb' 'readline')
+source=("https://www.libimobiledevice.org/downloads/$pkgname-$pkgver.tar.bz2")
+sha256sums=('cda0aba10a5b6fc2e1d83946b009e3e64d0be36912a986e35ad6d34b504ad9b4')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+}