summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x9fff002024-03-25 00:52:48 +0100
committer0x9fff002024-03-25 00:52:48 +0100
commitdbf00edf8802165f0cd378720ba85983d91051e9 (patch)
treee1f38752ceb9104c164d08fbaa430800b51b45c0
parentfb1168f8455967b0cea2edbf2e628755d5f503b5 (diff)
downloadaur-dbf00edf8802165f0cd378720ba85983d91051e9.tar.gz
libirecovery-1.0-3
-rw-r--r--.SRCINFO15
-rw-r--r--0001-Allow-building-without-tools.patch63
-rw-r--r--PKGBUILD33
-rwxr-xr-xautogen.sh26
4 files changed, 119 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3472fba7ec60..684a36be104b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
-pkgbase = libirecovery
- pkgdesc = Library and utility to talk to iBoot/iBSS via USB
+pkgbase = libirecovery-1.0-3
+ pkgdesc = Library and utility to talk to iBoot/iBSS via USB (libirecovery-1.0.so.3)
pkgver = 1.1.0
pkgrel = 1
url = https://libimobiledevice.org/
arch = x86_64
- license = LGPL2.1
- makedepends = systemd
+ license = LGPL-2.1-only
depends = libimobiledevice-glue
+ depends = libirecovery
depends = libusb
- depends = readline
source = https://github.com/libimobiledevice/libirecovery/releases/download/1.1.0/libirecovery-1.1.0.tar.bz2
+ source = 0001-Allow-building-without-tools.patch
+ source = autogen.sh
sha256sums = ee3b1afbc0cab5309492cfcf3e132c6cc002617a57664ee0120ae918318e25f9
+ sha256sums = 7fb1986bfaf4d92f7af8e13dce1c5a351897097ed18fc43b8845f8d830f61337
+ sha256sums = ae2f821eaef4444ceccf934d4ecb15ddeeeda08c80a9d7ece0b46fbcd3fcac87
-pkgname = libirecovery
+pkgname = libirecovery-1.0-3
diff --git a/0001-Allow-building-without-tools.patch b/0001-Allow-building-without-tools.patch
new file mode 100644
index 000000000000..1b05ad21b59c
--- /dev/null
+++ b/0001-Allow-building-without-tools.patch
@@ -0,0 +1,63 @@
+From f2a166b01445fe412b5bff1b71256aebd62d1fcb Mon Sep 17 00:00:00 2001
+From: Daniel VanBritsom <danthemann15@yahoo.com>
+Date: Fri, 6 Oct 2023 21:10:09 -0400
+Subject: [PATCH] Allow building --without-tools
+
+---
+ configure.ac | 18 +++++++++++++-----
+ tools/Makefile.am | 2 ++
+ 2 files changed, 15 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index e15231f..2b12d8f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -47,11 +47,6 @@ AC_TYPE_UINT8_T
+ # Checks for library functions.
+ AC_CHECK_FUNCS([strdup strerror strcasecmp strndup malloc realloc calloc])
+
+-# Checks for libraries.
+-AC_CHECK_HEADERS([readline/readline.h], [],
+- [AC_MSG_ERROR([Please install readline development headers])]
+-)
+-
+ # Check additional platform flags
+ AC_MSG_CHECKING([for platform-specific build settings])
+ case ${host_os} in
+@@ -100,6 +95,19 @@ if test "$ac_cv_attribute_constructor" = "yes"; then
+ AC_DEFINE(HAVE_ATTRIBUTE_CONSTRUCTOR, 1, [Define if the C compiler supports constructor/destructor attributes])
+ fi
+
++AC_ARG_WITH([tools],
++ [AS_HELP_STRING([--with-tools], [Build irecovery tools. (requires readline) [default=yes]])],
++ [],
++ [with_tools=yes])
++
++AS_IF([test "x$with_tools" = "xyes"], [
++ AC_DEFINE(BUILD_TOOLS, 1, [Define if we are building irecovery tools])
++ AC_CHECK_HEADERS([readline/readline.h], [],
++ [AC_MSG_ERROR([Please install readline development headers])]
++ )]
++)
++AM_CONDITIONAL(BUILD_TOOLS, test "x$with_tools" = "xyes")
++
+ AC_ARG_WITH([dummy],
+ [AS_HELP_STRING([--with-dummy], [Use no USB driver at all [default=no]. This is only useful if you just want to query the device list by product type or hardware model. All other operations are no-ops or will return IRECV_E_UNSUPPORTED.])],
+ [],
+diff --git a/tools/Makefile.am b/tools/Makefile.am
+index 03728b2..ebb085c 100644
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -1,3 +1,4 @@
++if BUILD_TOOLS
+ AM_CPPFLAGS = -I$(top_srcdir)/include
+
+ AM_CFLAGS = $(GLOBAL_CFLAGS) $(libusb_CFLAGS)
+@@ -9,3 +10,4 @@ irecovery_SOURCES = irecovery.c
+ irecovery_CFLAGS = $(AM_CFLAGS)
+ irecovery_LDFLAGS = $(AM_LDFLAGS)
+ irecovery_LDADD = $(top_builddir)/src/libirecovery-1.0.la
++endif
+--
+2.44.0
+
diff --git a/PKGBUILD b/PKGBUILD
index c06901274769..7bbeac6b30e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,44 @@
# Contributor: Ivan Shapovalov <intelfx@intelfx.name>
# Contributor: Matthew Bauer <mjbauer95@gmail.com>
-pkgname=libirecovery
+_name=libirecovery
+pkgname=$_name-1.0-3
pkgver=1.1.0
pkgrel=1
-pkgdesc="Library and utility to talk to iBoot/iBSS via USB"
+pkgdesc="Library and utility to talk to iBoot/iBSS via USB (libirecovery-1.0.so.3)"
arch=('x86_64')
url="https://libimobiledevice.org/"
-license=('LGPL2.1')
-depends=('libimobiledevice-glue' 'libusb' 'readline')
-# systemd is needed to build udev rules and is not in base-devel
-makedepends=('systemd')
-source=("https://github.com/libimobiledevice/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2")
-sha256sums=('ee3b1afbc0cab5309492cfcf3e132c6cc002617a57664ee0120ae918318e25f9')
+license=('LGPL-2.1-only')
+# libirecovery provides udev rules
+depends=('libimobiledevice-glue' 'libirecovery' 'libusb')
+source=("https://github.com/libimobiledevice/$_name/releases/download/$pkgver/$_name-$pkgver.tar.bz2"
+ '0001-Allow-building-without-tools.patch'
+ 'autogen.sh')
+sha256sums=('ee3b1afbc0cab5309492cfcf3e132c6cc002617a57664ee0120ae918318e25f9'
+ '7fb1986bfaf4d92f7af8e13dce1c5a351897097ed18fc43b8845f8d830f61337'
+ 'ae2f821eaef4444ceccf934d4ecb15ddeeeda08c80a9d7ece0b46fbcd3fcac87')
prepare() {
- cd "$pkgname-$pkgver"
+ cd "$_name-$pkgver"
# don't overlink to libplist-2.0.so
sed -Ei 's/(\$\(limd_glue_LIBS)\)/\1:-lplist-2.0=)/' src/Makefile.{am,in}
+
+ patch -Np1 -i "$srcdir/0001-Allow-building-without-tools.patch"
+ cp -a "$srcdir/autogen.sh" .
}
build() {
- cd "$pkgname-$pkgver"
+ cd "$_name-$pkgver"
- ./configure --prefix=/usr
+ ./autogen.sh --prefix=/usr --disable-static --without-tools
make
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$_name-$pkgver"
make DESTDIR="$pkgdir" install
+
+ rm -r "$pkgdir"/usr/{include,lib/{libirecovery-1.0.so,pkgconfig}}
}
diff --git a/autogen.sh b/autogen.sh
new file mode 100755
index 000000000000..5a0ec43ae561
--- /dev/null
+++ b/autogen.sh
@@ -0,0 +1,26 @@
+#!/bin/sh
+
+olddir=`pwd`
+srcdir=`dirname $0`
+test -z "$srcdir" && srcdir=.
+
+(
+ cd "$srcdir"
+
+ gprefix=`which glibtoolize 2>&1 >/dev/null`
+ if [ $? -eq 0 ]; then
+ glibtoolize --force
+ else
+ libtoolize --force
+ fi
+ aclocal -I m4
+ autoheader
+ automake --add-missing
+ autoconf
+
+ cd "$olddir"
+)
+
+if [ -z "$NOCONFIGURE" ]; then
+ $srcdir/configure "$@"
+fi