summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-06-04 00:20:37 +0800
committerChocobo12021-06-04 00:25:50 +0800
commitb54ad2a73bfb2cb0c75d391d6e83ad2283566ea5 (patch)
tree39c0760db98e397b64256b788ac05cf95e7c672f
downloadaur-b54ad2a73bfb2cb0c75d391d6e83ad2283566ea5.tar.gz
newpkg: libisoburn-git 1.5.4.r13.g60dfe77a-1
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD46
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1045b1f018c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = libisoburn-git
+ pkgdesc = Frontend for libburn and libisofs
+ pkgver = 1.5.4.r13.g60dfe77a
+ pkgrel = 1
+ url = https://dev.lovelyhq.com/libburnia/web/wiki/Libisoburn
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = glibc
+ depends = libburn
+ depends = libisofs
+ depends = readline
+ optdepends = tk: for xorriso-tcltk frontend
+ optdepends = sudo: for use with xorriso-dd-target
+ provides = libisoburn
+ provides = xorriso
+ provides = xorriso-tcltk
+ conflicts = libisoburn
+ options = staticlibs
+ source = git+https://dev.lovelyhq.com/libburnia/libisoburn.git
+ sha256sums = SKIP
+
+pkgname = libisoburn-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f39c60a5e25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libisoburn-git
+pkgver=1.5.4.r13.g60dfe77a
+pkgrel=1
+pkgdesc="Frontend for libburn and libisofs"
+arch=('i686' 'x86_64')
+url="https://dev.lovelyhq.com/libburnia/web/wiki/Libisoburn"
+license=('GPL')
+depends=('glibc' 'libburn' 'libisofs' 'readline')
+makedepends=('git')
+optdepends=('tk: for xorriso-tcltk frontend'
+ 'sudo: for use with xorriso-dd-target')
+provides=('libisoburn' 'xorriso' 'xorriso-tcltk')
+conflicts=('libisoburn')
+options=('staticlibs')
+source=("git+https://dev.lovelyhq.com/libburnia/libisoburn.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libisoburn"
+
+ git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libisoburn"
+
+ ./bootstrap
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "libisoburn"
+
+ make check
+}
+
+package() {
+ cd "libisoburn"
+
+ make DESTDIR="$pkgdir" install
+}