summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-08-28 22:25:50 +0800
committerChocobo12021-08-28 22:27:48 +0800
commita233fae55d230872f19b3e54e47aec29562e87b1 (patch)
tree38611a151bc4a516516aa611e5c63123a5ede582
parentf07bcd80fd53c99c9ff133e5182d3904ad9820af (diff)
downloadaur-a233fae55d230872f19b3e54e47aec29562e87b1.tar.gz
upgpkg: libisofs-git 1.5.4.r7.g1c4c04d-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8db7962896ac..379cb4fa0085 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libisofs-git
pkgdesc = Library to create an ISO-9660 filesystem
- pkgver = 1.5.4.rc1.r7.g1c4c04d
+ pkgver = 1.5.4.r7.g1c4c04d
pkgrel = 1
url = https://dev.lovelyhq.com/libburnia/web/wiki/Libisofs
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index a7c6978fa19e..cdc4dc4d1a2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libisofs-git
-pkgver=1.5.4.rc1.r7.g1c4c04d
+pkgver=1.5.4.r7.g1c4c04d
pkgrel=1
pkgdesc="Library to create an ISO-9660 filesystem"
arch=('i686' 'x86_64')
@@ -19,7 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "libisofs"
- git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ _tag=$(git tag -l --sort -v:refname | sed '/rc[0-9]*/d;/^v/d' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^release-//;s/-/./g'
}
build() {