summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-06-04 01:14:44 +0800
committerChocobo12021-06-04 01:16:06 +0800
commitf07bcd80fd53c99c9ff133e5182d3904ad9820af (patch)
tree41934caaf2aad3bcdbee5d585ef8b02952291a74
downloadaur-f07bcd80fd53c99c9ff133e5182d3904ad9820af.tar.gz
newpkg: libisofs-git 1.5.4.rc1.r7.g1c4c04d-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8db7962896ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libisofs-git
+ pkgdesc = Library to create an ISO-9660 filesystem
+ pkgver = 1.5.4.rc1.r7.g1c4c04d
+ pkgrel = 1
+ url = https://dev.lovelyhq.com/libburnia/web/wiki/Libisofs
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = glibc
+ depends = acl
+ depends = zlib
+ provides = libisofs
+ conflicts = libisofs
+ options = staticlibs
+ source = git+https://dev.lovelyhq.com/libburnia/libisofs.git
+ sha256sums = SKIP
+
+pkgname = libisofs-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7c6978fa19e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libisofs-git
+pkgver=1.5.4.rc1.r7.g1c4c04d
+pkgrel=1
+pkgdesc="Library to create an ISO-9660 filesystem"
+arch=('i686' 'x86_64')
+url="https://dev.lovelyhq.com/libburnia/web/wiki/Libisofs"
+license=('GPL')
+depends=('glibc' 'acl' 'zlib')
+makedepends=('git')
+provides=('libisofs')
+conflicts=('libisofs')
+options=('staticlibs')
+source=("git+https://dev.lovelyhq.com/libburnia/libisofs.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libisofs"
+
+ git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libisofs"
+
+ ./bootstrap
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "libisofs"
+
+ make check
+}
+
+package() {
+ cd "libisofs"
+
+ make DESTDIR="$pkgdir" install
+}