summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-04-22 01:27:34 +0000
committerDaniel Bermond2020-04-22 01:31:32 +0000
commit1f9c3abd8bfc83480dbd4552059df08fc7b49552 (patch)
tree7fa2ffefcfdc49650eaf5933ff77428b60524e8d
parent88275b0ce615ac29789d028c596705024c0adbb1 (diff)
downloadaur-1f9c3abd8bfc83480dbd4552059df08fc7b49552.tar.gz
Match latest upstream changes: update git submodules and fix build
-rw-r--r--.SRCINFO30
-rw-r--r--010-libjpeg-xl-git-remove-werror.patch6
-rw-r--r--020-libjpeg-xl-git-fix-headers-install-path.patch6
-rw-r--r--030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch8
-rw-r--r--040-libjpeg-xl-git-disable-avx2-avx512.patch33
-rw-r--r--040-libjpeg-xl-git-fix-highway-build.patch13
-rw-r--r--PKGBUILD57
7 files changed, 72 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a5ac688c7ac..1d155c770e1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,28 @@
pkgbase = libjpeg-xl-git
pkgdesc = JPEG XL image format reference implementation (git version)
- pkgver = r3.g0709f3a
- pkgrel = 4
+ pkgver = r4.gf84edfb
+ pkgrel = 1
url = https://jpeg.org/jpegxl/
arch = x86_64
license = Apache
makedepends = git
makedepends = cmake
makedepends = clang
- makedepends = libwebp
+ makedepends = giflib
+ makedepends = gperftools
+ makedepends = libjpeg-turbo
+ makedepends = libpng
makedepends = openexr
+ makedepends = zlib
+ makedepends = libgl
+ makedepends = freeglut
makedepends = gtest
makedepends = python
- makedepends = freeglut
- makedepends = gperftools
depends = gcc-libs
+ optdepends = giflib: for CLI tools
optdepends = gperftools: for CLI tools
- optdepends = libwebp: for CLI tools
+ optdepends = libjpeg-turbo: for CLI tools
+ optdepends = libpng: for CLI tools
optdepends = openexr: for CLI tools
provides = libjpeg-xl
conflicts = libjpeg-xl
@@ -28,10 +34,12 @@ pkgbase = libjpeg-xl-git
source = git+https://github.com/google/brunsli.git
source = git+https://github.com/webmproject/sjpeg.git
source = git+https://skia.googlesource.com/skcms.git
+ source = git+https://github.com/meganz/mingw-std-threads.git
source = 010-libjpeg-xl-git-remove-werror.patch
source = 020-libjpeg-xl-git-fix-headers-install-path.patch
source = 030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch
- source = 040-libjpeg-xl-git-disable-avx2-avx512.patch
+ source = 040-libjpeg-xl-git-fix-highway-build.patch
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -40,10 +48,10 @@ pkgbase = libjpeg-xl-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = f75738bb1041e1bf9104ca6156b2269f73e4503508803de183e57110b232bbfd
- sha256sums = ac5e30fb0a9034a935a463a3eaaec4b369fef6cf6e270cc85cce09e1f26f67c0
- sha256sums = 5d7df9a9cfc15183915b522bfa1360e0c9034c24c7630c0da43df35326b53c3c
- sha256sums = f94bdd66242ca0d9a9c32905fecdf43e9041eb36ac1d88dc2a1e7cc701a440aa
+ sha256sums = 0f538f216f7fca8611efd5d638b521eb2c3b1fb716720afb371f034b3165c90c
+ sha256sums = c2ea669a2afd94b6582921c893e0b382cd632c12d0a9c2358f955fd6cccffdc3
+ sha256sums = 1666790b92321fbf5859abe50c7355c91b0eddd7381529f35f052e71913c3bf0
+ sha256sums = 4011b3dccad3954d7090c8ab70e615ef23ba29958b888e88ecd85d76eaba7372
pkgname = libjpeg-xl-git
diff --git a/010-libjpeg-xl-git-remove-werror.patch b/010-libjpeg-xl-git-remove-werror.patch
index 3911c4425d52..8eb82fabec41 100644
--- a/010-libjpeg-xl-git-remove-werror.patch
+++ b/010-libjpeg-xl-git-remove-werror.patch
@@ -1,7 +1,7 @@
diff -Naurp a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2020-02-27 00:53:11.000000000 +0000
-+++ b/CMakeLists.txt 2020-02-27 00:53:13.000000000 +0000
-@@ -165,10 +165,6 @@ add_compile_options(
+--- a/CMakeLists.txt 2020-04-22 00:42:34.000000000 +0000
++++ b/CMakeLists.txt 2020-04-22 00:42:38.000000000 +0000
+@@ -154,10 +154,6 @@ add_compile_options(
-Wall
)
diff --git a/020-libjpeg-xl-git-fix-headers-install-path.patch b/020-libjpeg-xl-git-fix-headers-install-path.patch
index 9ab13e95244b..ca22218e2089 100644
--- a/020-libjpeg-xl-git-fix-headers-install-path.patch
+++ b/020-libjpeg-xl-git-fix-headers-install-path.patch
@@ -1,7 +1,7 @@
diff -Naurp a/jpegxl.cmake b/jpegxl.cmake
---- a/jpegxl.cmake 2020-02-27 00:53:11.000000000 +0000
-+++ b/jpegxl.cmake 2020-02-27 00:53:13.000000000 +0000
-@@ -437,9 +437,9 @@ endif() # APPLE
+--- a/jpegxl.cmake 2020-04-22 00:42:34.000000000 +0000
++++ b/jpegxl.cmake 2020-04-22 00:42:38.000000000 +0000
+@@ -457,9 +457,9 @@ endif() # APPLE
install(TARGETS jpegxl
DESTINATION ${CMAKE_INSTALL_LIBDIR})
install(DIRECTORY ${CMAKE_SOURCE_DIR}/include/jpegxl
diff --git a/030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch b/030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch
index 87da5dd43572..9a64d69f4098 100644
--- a/030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch
+++ b/030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch
@@ -1,9 +1,9 @@
diff -Naurp a/plugins/gdk-pixbuf/CMakeLists.txt b/plugins/gdk-pixbuf/CMakeLists.txt
---- a/plugins/gdk-pixbuf/CMakeLists.txt 2020-02-01 03:12:11.000000000 +0000
-+++ b/plugins/gdk-pixbuf/CMakeLists.txt 2020-02-01 03:29:15.820761981 +0000
+--- a/plugins/gdk-pixbuf/CMakeLists.txt 2020-04-22 00:42:34.000000000 +0000
++++ b/plugins/gdk-pixbuf/CMakeLists.txt 2020-04-22 00:42:38.000000000 +0000
@@ -24,9 +24,9 @@ endif ()
- add_library(pixbufloader-jxl SHARED pixbufloader-jxl.c c_interop.cc c_interop.h)
- target_link_libraries(pixbufloader-jxl jpegxl-static PkgConfig::Gdk-Pixbuf)
+ add_library(pixbufloader-jxl SHARED pixbufloader-jxl.c c_interop.cc c_interop.h)
+ target_link_libraries(pixbufloader-jxl jpegxl-static jpegxl_threads PkgConfig::Gdk-Pixbuf)
-install(TARGETS pixbufloader-jxl LIBRARY DESTINATION /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders)
+install(TARGETS pixbufloader-jxl LIBRARY DESTINATION /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders)
diff --git a/040-libjpeg-xl-git-disable-avx2-avx512.patch b/040-libjpeg-xl-git-disable-avx2-avx512.patch
deleted file mode 100644
index 1de271f8f975..000000000000
--- a/040-libjpeg-xl-git-disable-avx2-avx512.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Naurp a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2020-03-11 01:58:11.000000000 +0000
-+++ b/CMakeLists.txt 2020-03-11 02:07:10.472535286 +0000
-@@ -136,11 +136,8 @@ endif()
- # CPU flags
- if(${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86_64|AMD64" AND NOT MSVC)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} \
-- -mavx2 \
-- -mfma \
-- -Xclang -mprefer-vector-width=128 \
-- -Xclang -target-cpu -Xclang haswell \
-- -Xclang -target-feature -Xclang +avx2")
-+ -msse4.1 \
-+ -Xclang -target-feature -Xclang +sse4.1")
- elseif(${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86_64|AMD64" AND MSVC)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /arch:AVX2")
- elseif(${CMAKE_SYSTEM_PROCESSOR} MATCHES "aarch64")
-diff -Naurp a/third_party/highway/hwy/targets.h b/third_party/highway/hwy/targets.h
---- a/third_party/highway/hwy/targets.h 2020-03-11 01:58:08.000000000 +0000
-+++ b/third_party/highway/hwy/targets.h 2020-03-11 02:00:17.338460487 +0000
-@@ -25,10 +25,10 @@
- #define HWY_WASM 32
-
- // Uncomment to avoid using/requiring AVX2 when running on Intel/AMD.
--// #define HWY_DISABLE_AVX2
-+#define HWY_DISABLE_AVX2
-
- // Uncomment to avoid additional (optional) code generation for AVX-512 when
- // building for Intel/AMD.
--// #define HWY_DISABLE_AVX512
-+#define HWY_DISABLE_AVX512
-
- #endif // HWY_TARGETS_H_
diff --git a/040-libjpeg-xl-git-fix-highway-build.patch b/040-libjpeg-xl-git-fix-highway-build.patch
new file mode 100644
index 000000000000..84c3d3678e4a
--- /dev/null
+++ b/040-libjpeg-xl-git-fix-highway-build.patch
@@ -0,0 +1,13 @@
+diff -Naurp a/third_party/highway/CMakeLists.txt b/third_party/highway/CMakeLists.txt
+--- a/third_party/highway/CMakeLists.txt 2020-04-22 00:42:34.000000000 +0000
++++ b/third_party/highway/CMakeLists.txt 2020-04-22 00:43:41.699909851 +0000
+@@ -72,6 +72,9 @@ set(HWY_FLAGS
+ -Wnon-virtual-dtor
+ -Woverloaded-virtual
+ -Wvla
++
++ # Build fixes
++ -fPIC
+ )
+
+ if(${CMAKE_CXX_COMPILER_ID} MATCHES "Clang")
diff --git a/PKGBUILD b/PKGBUILD
index ccf28c85aa0b..0d68e716e8a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=libjpeg-xl-git
-pkgver=r3.g0709f3a
-pkgrel=4
+pkgver=r4.gf84edfb
+pkgrel=1
pkgdesc='JPEG XL image format reference implementation (git version)'
arch=('x86_64')
url='https://jpeg.org/jpegxl/'
license=('Apache')
depends=('gcc-libs')
-optdepends=('gperftools: for CLI tools'
- 'libwebp: for CLI tools'
+optdepends=('giflib: for CLI tools'
+ 'gperftools: for CLI tools'
+ 'libjpeg-turbo: for CLI tools'
+ 'libpng: for CLI tools'
'openexr: for CLI tools')
-makedepends=('git' 'cmake' 'clang' 'libwebp' 'openexr' 'gtest' 'python' 'freeglut'
- 'gperftools')
+makedepends=('git' 'cmake' 'clang' 'giflib' 'gperftools' 'libjpeg-turbo'
+ 'libpng' 'openexr' 'zlib' 'libgl' 'freeglut' 'gtest' 'python')
provides=('libjpeg-xl')
conflicts=('libjpeg-xl')
source=('git+https://gitlab.com/wg1/jpeg-xl.git'
@@ -23,10 +25,11 @@ source=('git+https://gitlab.com/wg1/jpeg-xl.git'
'git+https://github.com/google/brunsli.git'
'git+https://github.com/webmproject/sjpeg.git'
'git+https://skia.googlesource.com/skcms.git'
+ 'git+https://github.com/meganz/mingw-std-threads.git'
'010-libjpeg-xl-git-remove-werror.patch'
'020-libjpeg-xl-git-fix-headers-install-path.patch'
'030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch'
- '040-libjpeg-xl-git-disable-avx2-avx512.patch')
+ '040-libjpeg-xl-git-fix-highway-build.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -35,31 +38,31 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'f75738bb1041e1bf9104ca6156b2269f73e4503508803de183e57110b232bbfd'
- 'ac5e30fb0a9034a935a463a3eaaec4b369fef6cf6e270cc85cce09e1f26f67c0'
- '5d7df9a9cfc15183915b522bfa1360e0c9034c24c7630c0da43df35326b53c3c'
- 'f94bdd66242ca0d9a9c32905fecdf43e9041eb36ac1d88dc2a1e7cc701a440aa')
+ 'SKIP'
+ '0f538f216f7fca8611efd5d638b521eb2c3b1fb716720afb371f034b3165c90c'
+ 'c2ea669a2afd94b6582921c893e0b382cd632c12d0a9c2358f955fd6cccffdc3'
+ '1666790b92321fbf5859abe50c7355c91b0eddd7381529f35f052e71913c3bf0'
+ '4011b3dccad3954d7090c8ab70e615ef23ba29958b888e88ecd85d76eaba7372')
prepare() {
- cd jpeg-xl
- git submodule init
- git config --local submodule.third_party/brotli.url "${srcdir}/brotli"
- git config --local submodule.third_party/lodepng.url "${srcdir}/lodepng"
- git config --local submodule.third_party/lcms.url "${srcdir}/Little-CMS"
- git config --local submodule.third_party/googletest.url "${srcdir}/googletest"
- git config --local submodule.third_party/brunsli.url "${srcdir}/brunsli"
- git config --local submodule.third_party/sjpeg.url "${srcdir}/sjpeg"
- git config --local submodule.third_party/skcms.url "${srcdir}/skcms"
- git submodule update
- patch -Np1 -i "${srcdir}/010-libjpeg-xl-git-remove-werror.patch"
- patch -Np1 -i "${srcdir}/020-libjpeg-xl-git-fix-headers-install-path.patch"
- patch -Np1 -i "${srcdir}/030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch"
- patch -Np1 -i "${srcdir}/040-libjpeg-xl-git-disable-avx2-avx512.patch"
+ git -C jpeg-xl submodule init
+ git -C jpeg-xl config --local submodule.third_party/brotli.url "${srcdir}/brotli"
+ git -C jpeg-xl config --local submodule.third_party/lodepng.url "${srcdir}/lodepng"
+ git -C jpeg-xl config --local submodule.third_party/lcms.url "${srcdir}/Little-CMS"
+ git -C jpeg-xl config --local submodule.third_party/googletest.url "${srcdir}/googletest"
+ git -C jpeg-xl config --local submodule.third_party/brunsli.url "${srcdir}/brunsli"
+ git -C jpeg-xl config --local submodule.third_party/sjpeg.url "${srcdir}/sjpeg"
+ git -C jpeg-xl config --local submodule.third_party/skcms.url "${srcdir}/skcms"
+ git -C jpeg-xl config --local submodule.third_party/mingw-std-threads.url "${srcdir}/mingw-std-threads"
+ git -C jpeg-xl submodule update
+ patch -d jpeg-xl -Np1 -i "${srcdir}/010-libjpeg-xl-git-remove-werror.patch"
+ patch -d jpeg-xl -Np1 -i "${srcdir}/020-libjpeg-xl-git-fix-headers-install-path.patch"
+ patch -d jpeg-xl -Np1 -i "${srcdir}/030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch"
+ patch -d jpeg-xl -Np1 -i "${srcdir}/040-libjpeg-xl-git-fix-highway-build.patch"
}
pkgver() {
- cd jpeg-xl
- printf 'r%s.g%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf 'r%s.g%s' "$(git -C jpeg-xl rev-list --count HEAD)" "$(git -C jpeg-xl rev-parse --short HEAD)"
}
build() {