summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-11-16 19:18:21 +0000
committerDaniel Bermond2020-11-16 19:18:21 +0000
commit5ebde807edee476033cdaa62fa3de04abbb8074d (patch)
treee08923f586560c8525232acbe9e23d00a97b7832
parent3efe015921f7bc26c35419e926ec1c936fab59a4 (diff)
downloadaur-5ebde807edee476033cdaa62fa3de04abbb8074d.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3ce037fa963..60d31eb77cfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libjpeg-xl-git
pkgdesc = JPEG XL image format reference implementation (git version)
- pkgver = r26.g4d70bd5
+ pkgver = r28.gd5ab3c6
pkgrel = 1
url = https://jpeg.org/jpegxl/
arch = x86_64
@@ -30,10 +30,10 @@ pkgbase = libjpeg-xl-git
source = git+https://github.com/google/brunsli.git
source = git+https://github.com/webmproject/sjpeg.git
source = git+https://skia.googlesource.com/skcms.git
- source = git+https://github.com/meganz/mingw-std-threads.git
source = git+https://github.com/veluca93/IQA-optimization.git
source = git+https://github.com/Netflix/vmaf.git
source = git+https://github.com/thorfdbg/difftest_ng.git
+ source = git+https://github.com/google/highway.git
source = 010-libjpeg-xl-git-fix-highway-build.patch
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e10600d403cb..f7415d5203a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=libjpeg-xl-git
pkgname=('libjpeg-xl-git' 'libjpeg-xl-doc-git')
-pkgver=r26.g4d70bd5
+pkgver=r28.gd5ab3c6
pkgrel=1
pkgdesc='JPEG XL image format reference implementation (git version)'
arch=('x86_64')
@@ -19,10 +19,10 @@ source=('git+https://gitlab.com/wg1/jpeg-xl.git'
'git+https://github.com/google/brunsli.git'
'git+https://github.com/webmproject/sjpeg.git'
'git+https://skia.googlesource.com/skcms.git'
- 'git+https://github.com/meganz/mingw-std-threads.git'
'git+https://github.com/veluca93/IQA-optimization.git'
'git+https://github.com/Netflix/vmaf.git'
'git+https://github.com/thorfdbg/difftest_ng.git'
+ 'git+https://github.com/google/highway.git'
'010-libjpeg-xl-git-fix-highway-build.patch')
sha256sums=('SKIP'
'SKIP'
@@ -39,10 +39,6 @@ sha256sums=('SKIP'
'f783be03afe7094e21281097da0c727a83317dad118f15d36691f7f14163efa5')
prepare() {
- local _mingw_commit
- _mingw_commit="$(git -C jpeg-xl submodule | awk '/mingw-std-threads/ { sub(/^-/, "", $1); print $1 }')"
- git -C mingw-std-threads remote add upstream https://github.com/meganz/mingw-std-threads.git
- git -C mingw-std-threads fetch upstream "$_mingw_commit"
git -C jpeg-xl submodule init
git -C jpeg-xl config --local submodule.third_party/brotli.url "${srcdir}/brotli"
git -C jpeg-xl config --local submodule.third_party/lodepng.url "${srcdir}/lodepng"
@@ -55,6 +51,7 @@ prepare() {
git -C jpeg-xl config --local submodule.third_party/IQA-optimization.url "${srcdir}/IQA-optimization"
git -C jpeg-xl config --local submodule.third_party/vmaf.url "${srcdir}/vmaf"
git -C jpeg-xl config --local submodule.third_party/difftest_ng.url "${srcdir}/difftest_ng"
+ git -C jpeg-xl config --local submodule.third_party/highway.url "${srcdir}/highway"
git -C jpeg-xl submodule update
patch -d jpeg-xl -Np1 -i "${srcdir}/010-libjpeg-xl-git-fix-highway-build.patch"
}
@@ -74,6 +71,8 @@ build() {
-DJPEGXL_ENABLE_PLUGINS:BOOL='true' \
-DJPEGXL_ENABLE_VIEWERS:BOOL='false' \
-DJPEGXL_WARNINGS_AS_ERRORS:BOOL='false' \
+ -DGTEST_LIBRARY:FILEPATH='/usr/lib/libgtest.so' \
+ -DGTEST_MAIN_LIBRARY:FILEPATH='/usr/lib/libgtest_main.so' \
-Wno-dev
make -C build all doc
}