summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-05-06 21:08:17 +0000
committerDaniel Bermond2020-05-06 22:17:29 +0000
commit8100f7772b08633df9422ad0a1256e4718966c60 (patch)
treed46e34230acf91826a3435fee0df2720cf432ea5
parent1f9c3abd8bfc83480dbd4552059df08fc7b49552 (diff)
downloadaur-8100f7772b08633df9422ad0a1256e4718966c60.tar.gz
Fix build: issue with submodule mingw-std-threads
Submodule mingw-std-threads is targeting an untracked commit (or something of that sort). The target commit cannot be checked out by makepkg sources (makepkg gives an error when using '#commit=<hash>'), but it's available for fetching at upstream, so I'm manually fetching it at prepare(). It seems that the target commit was somehow moved by upstream mingw-std-threads, because it was working previously and now it stopped to work. Maybe they deleted it from its branch.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d155c770e1f..40ea7c1365ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libjpeg-xl-git
pkgdesc = JPEG XL image format reference implementation (git version)
pkgver = r4.gf84edfb
- pkgrel = 1
+ pkgrel = 2
url = https://jpeg.org/jpegxl/
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 0d68e716e8a0..88fa149b3cbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libjpeg-xl-git
pkgver=r4.gf84edfb
-pkgrel=1
+pkgrel=2
pkgdesc='JPEG XL image format reference implementation (git version)'
arch=('x86_64')
url='https://jpeg.org/jpegxl/'
@@ -45,6 +45,10 @@ sha256sums=('SKIP'
'4011b3dccad3954d7090c8ab70e615ef23ba29958b888e88ecd85d76eaba7372')
prepare() {
+ local _mingw_commit
+ _mingw_commit="$(git -C jpeg-xl submodule | awk '/mingw-std-threads/ { sub(/^-/, "", $1); print $1 }')"
+ git -C mingw-std-threads remote add upstream https://github.com/meganz/mingw-std-threads.git
+ git -C mingw-std-threads fetch upstream "$_mingw_commit"
git -C jpeg-xl submodule init
git -C jpeg-xl config --local submodule.third_party/brotli.url "${srcdir}/brotli"
git -C jpeg-xl config --local submodule.third_party/lodepng.url "${srcdir}/lodepng"