summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-03-02 01:43:32 +0000
committerDaniel Bermond2020-03-02 01:43:32 +0000
commitfe01c971eafa79543f298d5e6badf10eee3f8497 (patch)
tree5e96f08fda4d2217244e480e843b4e575b0e8fb9
parenta702413c4316954b0e767651040fe5cd73378d0d (diff)
downloadaur-fe01c971eafa79543f298d5e6badf10eee3f8497.tar.gz
Disable AVX512. Remove benchmark tool.
-rw-r--r--.SRCINFO6
-rw-r--r--040-libjpeg-xl-git-disable-avx2-avx512.patch (renamed from 040-libjpeg-xl-git-disable-avx2.patch)12
-rw-r--r--PKGBUILD10
3 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efd8959a25c7..a13cdbe675ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libjpeg-xl-git
pkgdesc = JPEG XL image format reference implementation (git version)
pkgver = r3.g0709f3a
- pkgrel = 1
+ pkgrel = 2
url = https://jpeg.org/jpegxl/
arch = x86_64
license = Apache
@@ -31,7 +31,7 @@ pkgbase = libjpeg-xl-git
source = 010-libjpeg-xl-git-remove-werror.patch
source = 020-libjpeg-xl-git-fix-headers-install-path.patch
source = 030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch
- source = 040-libjpeg-xl-git-disable-avx2.patch
+ source = 040-libjpeg-xl-git-disable-avx2-avx512.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -43,7 +43,7 @@ pkgbase = libjpeg-xl-git
sha256sums = f75738bb1041e1bf9104ca6156b2269f73e4503508803de183e57110b232bbfd
sha256sums = ac5e30fb0a9034a935a463a3eaaec4b369fef6cf6e270cc85cce09e1f26f67c0
sha256sums = 5d7df9a9cfc15183915b522bfa1360e0c9034c24c7630c0da43df35326b53c3c
- sha256sums = 403600ccf265966d6a03607591daab4f4129c82a0dc467e5f6b02e4762c1e341
+ sha256sums = 74497628c1f689ab511aceb1ffb13480a1a55552a45f794fcbe3b209b91ebd28
pkgname = libjpeg-xl-git
diff --git a/040-libjpeg-xl-git-disable-avx2.patch b/040-libjpeg-xl-git-disable-avx2-avx512.patch
index 39b6517e3436..78d2e5a1e4ff 100644
--- a/040-libjpeg-xl-git-disable-avx2.patch
+++ b/040-libjpeg-xl-git-disable-avx2-avx512.patch
@@ -1,4 +1,4 @@
-diff -Naupr a/CMakeLists.txt b/CMakeLists.txt
+diff -Naurp a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt 2020-03-01 20:39:57.000000000 +0000
+++ b/CMakeLists.txt 2020-03-01 23:39:56.619280694 +0000
@@ -134,16 +134,7 @@ else()
@@ -19,10 +19,10 @@ diff -Naupr a/CMakeLists.txt b/CMakeLists.txt
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} \
-Xclang -mprefer-vector-width=128 \
-Xclang -target-cpu -Xclang cortex-a72")
-diff -Naupr a/third_party/highway/hwy/targets.h b/third_party/highway/hwy/targets.h
+diff -Naurp a/third_party/highway/hwy/targets.h b/third_party/highway/hwy/targets.h
--- a/third_party/highway/hwy/targets.h 2020-03-01 20:30:01.000000000 +0000
-+++ b/third_party/highway/hwy/targets.h 2020-03-01 20:32:10.234611054 +0000
-@@ -25,7 +25,7 @@
++++ b/third_party/highway/hwy/targets.h 2020-03-02 01:26:53.807156122 +0000
+@@ -25,10 +25,10 @@
#define HWY_WASM 32
// Uncomment to avoid using/requiring AVX2 when running on Intel/AMD.
@@ -31,3 +31,7 @@ diff -Naupr a/third_party/highway/hwy/targets.h b/third_party/highway/hwy/target
// Uncomment to avoid additional (optional) code generation for AVX-512 when
// building for Intel/AMD.
+-// #define HWY_DISABLE_AVX512
++#define HWY_DISABLE_AVX512
+
+ #endif // HWY_TARGETS_H_
diff --git a/PKGBUILD b/PKGBUILD
index 5e8e733b1087..ba7b182f4a38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libjpeg-xl-git
pkgver=r3.g0709f3a
-pkgrel=1
+pkgrel=2
pkgdesc='JPEG XL image format reference implementation (git version)'
arch=('x86_64')
url='https://jpeg.org/jpegxl/'
@@ -26,7 +26,7 @@ source=('git+https://gitlab.com/wg1/jpeg-xl.git'
'010-libjpeg-xl-git-remove-werror.patch'
'020-libjpeg-xl-git-fix-headers-install-path.patch'
'030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch'
- '040-libjpeg-xl-git-disable-avx2.patch')
+ '040-libjpeg-xl-git-disable-avx2-avx512.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -38,7 +38,7 @@ sha256sums=('SKIP'
'f75738bb1041e1bf9104ca6156b2269f73e4503508803de183e57110b232bbfd'
'ac5e30fb0a9034a935a463a3eaaec4b369fef6cf6e270cc85cce09e1f26f67c0'
'5d7df9a9cfc15183915b522bfa1360e0c9034c24c7630c0da43df35326b53c3c'
- '403600ccf265966d6a03607591daab4f4129c82a0dc467e5f6b02e4762c1e341')
+ '74497628c1f689ab511aceb1ffb13480a1a55552a45f794fcbe3b209b91ebd28')
prepare() {
cd jpeg-xl
@@ -54,7 +54,7 @@ prepare() {
patch -Np1 -i "${srcdir}/010-libjpeg-xl-git-remove-werror.patch"
patch -Np1 -i "${srcdir}/020-libjpeg-xl-git-fix-headers-install-path.patch"
patch -Np1 -i "${srcdir}/030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch"
- patch -Np1 -i "${srcdir}/040-libjpeg-xl-git-disable-avx2.patch"
+ patch -Np1 -i "${srcdir}/040-libjpeg-xl-git-disable-avx2-avx512.patch"
}
pkgver() {
@@ -68,7 +68,7 @@ build() {
cmake -B build -S jpeg-xl \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
- -DJPEGXL_ENABLE_BENCHMARK:BOOL='true' \
+ -DJPEGXL_ENABLE_BENCHMARK:BOOL='false' \
-DJPEGXL_ENABLE_FUZZERS:BOOL='false' \
-DJPEGXL_ENABLE_PLUGINS:BOOL='false' \
-DJPEGXL_ENABLE_VIEWERS:BOOL='false' \