summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-08-03 15:28:30 +0000
committerDaniel Bermond2021-08-03 15:28:30 +0000
commit3b856805ae63090a3aba83cc02a7950c74c50dba (patch)
tree9fd1768e77994bd3664fee1ddc4d579f397cadd8
parent41bfaf9688f840c8c09032061b0ea33677fa15c5 (diff)
downloadaur-3b856805ae63090a3aba83cc02a7950c74c50dba.tar.gz
Add fix for jdk7
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57afcb6a93d8..5146b6857f4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libjxl
pkgdesc = JPEG XL image format reference implementation
pkgver = 0.5
- pkgrel = 2
+ pkgrel = 3
url = https://jpeg.org/jpegxl/
arch = x86_64
license = BSD
@@ -38,6 +38,7 @@ pkgbase = libjxl
source = git+https://github.com/Netflix/vmaf.git
source = git+https://github.com/thorfdbg/difftest_ng.git
source = git+https://github.com/google/highway.git
+ source = 010-libjxl-jdk7-fix.patch::https://github.com/libjxl/libjxl/commit/76df97ea2d7e91ceecc778d7c098dc376209ee73.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -49,6 +50,7 @@ pkgbase = libjxl
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 40e22d47f073b8ccc9382451449360e01afed96ce5d80c89ff82ae8babb96303
pkgname = libjxl
depends = brotli
diff --git a/PKGBUILD b/PKGBUILD
index fa477971a8a6..1a92ec420920 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=libjxl
pkgname=('libjxl' 'libjxl-doc')
pkgver=0.5
-pkgrel=2
+pkgrel=3
pkgdesc='JPEG XL image format reference implementation'
arch=('x86_64')
url='https://jpeg.org/jpegxl/'
@@ -22,7 +22,8 @@ source=("git+https://github.com/libjxl/libjxl.git#tag=v${pkgver}"
'git+https://github.com/veluca93/IQA-optimization.git'
'git+https://github.com/Netflix/vmaf.git'
'git+https://github.com/thorfdbg/difftest_ng.git'
- 'git+https://github.com/google/highway.git')
+ 'git+https://github.com/google/highway.git'
+ '010-libjxl-jdk7-fix.patch'::'https://github.com/libjxl/libjxl/commit/76df97ea2d7e91ceecc778d7c098dc376209ee73.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -33,7 +34,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '40e22d47f073b8ccc9382451449360e01afed96ce5d80c89ff82ae8babb96303')
prepare() {
git -C libjxl submodule init
@@ -48,6 +50,9 @@ prepare() {
git -C libjxl config --local submodule.third_party/difftest_ng.url "${srcdir}/difftest_ng"
git -C libjxl config --local submodule.third_party/highway.url "${srcdir}/highway"
git -C libjxl submodule update
+
+ # https://github.com/libjxl/libjxl/issues/396
+ patch -d libjxl -Np1 -i "${srcdir}/010-libjxl-jdk7-fix.patch"
}
build() {