summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-04-25 12:39:23 -0300
committerDaniel Bermond2022-04-25 12:39:23 -0300
commit18252781c6ba1f6d372c8beff6bf99d4ae7bd0b0 (patch)
tree98344f9943748fe3a388438452c021b180de6193
parent2f1260eade134e53e6d32f083e1c3f9a757dd013 (diff)
downloadaur-18252781c6ba1f6d372c8beff6bf99d4ae7bd0b0.tar.gz
Match latest upstream changes. Switch compiler to gcc.
Switching compiler to gcc allows to enable lto.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD36
2 files changed, 21 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a82c9041b83e..71a627f9332a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libjxl-git
pkgdesc = JPEG XL image format reference implementation (git version)
- pkgver = 0.3.7.r832.gd98c7071
+ pkgver = 0.3.7.r991.g88bfed80
pkgrel = 1
url = https://jpeg.org/jpegxl/
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = libjxl-git
makedepends = giflib
makedepends = gimp
makedepends = gperftools
+ makedepends = highway-git
makedepends = libjpeg-turbo
makedepends = libpng
makedepends = openexr
@@ -24,8 +25,6 @@ pkgbase = libjxl-git
makedepends = doxygen
makedepends = graphviz
makedepends = xdg-utils
- makedepends = highway-git
- options = !lto
source = git+https://github.com/libjxl/libjxl.git
source = git+https://github.com/google/brotli.git
source = git+https://github.com/mm2/Little-CMS.git
@@ -36,6 +35,8 @@ pkgbase = libjxl-git
source = git+https://github.com/glennrp/libpng.git
source = git+https://github.com/madler/zlib.git
source = git+https://github.com/gflags/gflags.git
+ source = libjxl-testdata::git+https://github.com/libjxl/testdata.git
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 71e0da4975e2..b853be4d111a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,16 @@
pkgbase=libjxl-git
pkgname=('libjxl-git' 'libjxl-doc-git')
-pkgver=0.3.7.r832.gd98c7071
+pkgver=0.3.7.r991.g88bfed80
pkgrel=1
pkgdesc='JPEG XL image format reference implementation (git version)'
arch=('x86_64')
url='https://jpeg.org/jpegxl/'
license=('BSD')
makedepends=('git' 'cmake' 'clang' 'brotli' 'gdk-pixbuf2' 'giflib' 'gimp'
- 'gperftools' 'libjpeg-turbo' 'libpng' 'openexr' 'gflags'
- 'gtest' 'java-environment' 'python' 'asciidoc' 'doxygen'
- 'graphviz' 'xdg-utils' 'highway-git')
-options=('!lto')
+ 'gperftools' 'highway-git' 'libjpeg-turbo' 'libpng' 'openexr'
+ 'gflags' 'gtest' 'java-environment' 'python' 'asciidoc'
+ 'doxygen' 'graphviz' 'xdg-utils')
source=('git+https://github.com/libjxl/libjxl.git'
'git+https://github.com/google/brotli.git'
'git+https://github.com/mm2/Little-CMS.git'
@@ -22,7 +21,8 @@ source=('git+https://github.com/libjxl/libjxl.git'
'git+https://github.com/google/highway.git'
'git+https://github.com/glennrp/libpng.git'
'git+https://github.com/madler/zlib.git'
- 'git+https://github.com/gflags/gflags.git')
+ 'git+https://github.com/gflags/gflags.git'
+ 'libjxl-testdata'::'git+https://github.com/libjxl/testdata.git')
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -32,19 +32,18 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
git -C libjxl submodule init
- git -C libjxl config --local submodule.third_party/brotli.url "${srcdir}/brotli"
+ local _submodule
+ for _submodule in brotli googletest sjpeg skcms highway libpng zlib gflags
+ do
+ git -C libjxl config --local "submodule.third_party/${_submodule}.url" "${srcdir}/${_submodule}"
+ done
git -C libjxl config --local submodule.third_party/lcms.url "${srcdir}/Little-CMS"
- git -C libjxl config --local submodule.third_party/googletest.url "${srcdir}/googletest"
- git -C libjxl config --local submodule.third_party/sjpeg.url "${srcdir}/sjpeg"
- git -C libjxl config --local submodule.third_party/skcms.url "${srcdir}/skcms"
- git -C libjxl config --local submodule.third_party/highway.url "${srcdir}/highway"
- git -C libjxl config --local submodule.third_party/libpng.url "${srcdir}/libpng"
- git -C libjxl config --local submodule.third_party/zlib.url "${srcdir}/zlib"
- git -C libjxl config --local submodule.third_party/gflags.url "${srcdir}/gflags"
+ git -C libjxl config --local submodule.third_party/testdata.url "${srcdir}/libjxl-testdata"
git -C libjxl submodule update
}
@@ -53,10 +52,8 @@ pkgver() {
}
build() {
- export CC='clang'
- export CXX='clang++'
- export CFLAGS+=' -DNDEBUG'
- export CXXFLAGS+=' -DNDEBUG'
+ export CFLAGS+=' -DNDEBUG -ffat-lto-objects'
+ export CXXFLAGS+=' -DNDEBUG -ffat-lto-objects'
cmake -B build -S libjxl \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
@@ -70,6 +67,7 @@ build() {
-DJPEGXL_FORCE_SYSTEM_HWY:BOOL='true' \
-DJPEGXL_BUNDLE_LIBPNG:BOOL='NO' \
-DJPEGXL_BUNDLE_GFLAGS='NO' \
+ -DJPEGXL_INSTALL_JARDIR='/usr/share/java' \
-Wno-dev
make -C build all doc
}
@@ -89,8 +87,8 @@ package_libjxl-git() {
replaces=('libjpeg-xl-git')
make -C build DESTDIR="$pkgdir" install
- install -D -m755 build/tools/libjxl_jni.so -t "${pkgdir}/usr/lib"
install -D -m644 libjxl/{LICENSE,PATENTS} -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ mv "${pkgdir}/usr/share/java"/{org.jpeg.jpegxl,jpegxl}.jar
}
package_libjxl-doc-git() {