summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Holmer2022-10-29 11:57:17 -0400
committerJosh Holmer2022-10-29 11:57:17 -0400
commit94e61064b4625e91c6034a091cf0fe6705da5c40 (patch)
tree2272d1a19a2b5bce2fdbe5d17ce656c0f993ab7d
parent4eab9bdb608d0922e721a7b214571245ecbdc305 (diff)
downloadaur-94e61064b4625e91c6034a091cf0fe6705da5c40.tar.gz
Fixes from discord
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa4920fc30cc..d6c0c919815c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libjxl-metrics-git
pkgdesc = JPEG XL image format reference implementation with butteraugli, ssimulacra, and ssimulacra2 (git version)
- pkgver = v0.7.base.29.g1c19bb48
+ pkgver = 0.7.0.r99.g506714ed
pkgrel = 1
url = https://jpeg.org/jpegxl/
arch = x86_64
@@ -63,6 +63,8 @@ pkgbase = libjxl-metrics-git
source = libpng::git+https://github.com/glennrp/libpng.git
source = zlib::git+https://github.com/madler/zlib.git
source = gflags::git+https://github.com/gflags/gflags.git
+ source = libjxl-testdata::git+https://github.com/libjxl/testdata.git
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a48842ac2243..89d9adba489a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Joshua Holmer <jholmer.in@gmail.com>
pkgname=libjxl-metrics-git
-pkgver=v0.7.base.29.g1c19bb48
+pkgver=0.7.0.r99.g506714ed
pkgrel=1
pkgdesc="JPEG XL image format reference implementation with butteraugli, ssimulacra, and ssimulacra2 (git version)"
arch=('x86_64')
@@ -40,6 +40,7 @@ source=(
'libpng::git+https://github.com/glennrp/libpng.git'
'zlib::git+https://github.com/madler/zlib.git'
'gflags::git+https://github.com/gflags/gflags.git'
+ 'libjxl-testdata::git+https://github.com/libjxl/testdata.git'
)
sha256sums=(
'SKIP'
@@ -52,6 +53,7 @@ sha256sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)
options=('!lto')
@@ -66,12 +68,15 @@ prepare() {
git -C libjxl config --local submodule.third_party/libpng.url "${srcdir}/libpng"
git -C libjxl config --local submodule.third_party/zlib.url "${srcdir}/zlib"
git -C libjxl config --local submodule.third_party/gflags.url "${srcdir}/gflags"
- git -C libjxl submodule update
+ git -C libjxl config --local submodule.third_party/testdata.url "${srcdir}/libjxl-testdata"
+ git -C libjxl -c protocol.file.allow='always' submodule update
}
pkgver() {
- cd libjxl
- echo "$(git describe --long --tags | tr - .)"
+ local _tag
+ _tag="$(git -C libjxl tag --list --sort='-v:refname' 'v[[:digit:]]*' | sed 's/^v//;/[[:alpha:]]/d' | head -n1)"
+ printf "${_tag}.r%s.g%s" "$(git -C libjxl rev-list --count "v${_tag}..HEAD")" \
+ "$(git -C libjxl rev-parse --short HEAD)"
}
build() {
@@ -124,6 +129,4 @@ package() {
ln -s "/usr/lib/libjxl.so.0.8.0" "$pkgdir/usr/lib/libjxl.so.0.7.0"
ln -s "/usr/lib/libjxl_threads.so.0.8.0" "$pkgdir/usr/lib/libjxl_threads.so.0.7"
ln -s "/usr/lib/libjxl_threads.so.0.8.0" "$pkgdir/usr/lib/libjxl_threads.so.0.7.0"
-
-
}