summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2020-02-07 17:04:09 +0100
committerLubosz Sarnecki2020-02-07 17:04:27 +0100
commit682acf733815bce6df0d49113f866b2e374b6a57 (patch)
tree585e538937b367ae39e9bae9afb12a370ed793f4
parent88ee39a909e4e9576dbaf94a68855e2e48a35051 (diff)
downloadaur-682acf733815bce6df0d49113f866b2e374b6a57.tar.gz
Fix optdepend and use python3 for compileall.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e4655cf6674..0970e0c0a436 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,7 @@ pkgbase = libkate-python3-git
depends = libpng
depends = libogg
depends = python3
- optdepends = wxpython: for KateDJ
+ optdepends = python-wxpython: for KateDJ
optdepends = liboggz: for KateDJ
provides = libkate=0.4.1
conflicts = libkate
diff --git a/PKGBUILD b/PKGBUILD
index 525b95f3a323..a62d74cba248 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ conflicts=('libkate')
replaces=('libkate')
provides=('libkate='${pkgver})
makedepends=('pkg-config' 'git')
-optdepends=('wxpython: for KateDJ'
+optdepends=('python-wxpython: for KateDJ'
'liboggz: for KateDJ')
source=("$pkgname::git+https://gitlab.com/lubosz/kate.git#branch=python3")
sha512sums=('SKIP')
@@ -41,5 +41,5 @@ package() {
make DESTDIR="${pkgdir}" install
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- python2 -m compileall "${pkgdir}/usr/lib/python3.8/site-packages/kdj/"
+ python3 -m compileall "${pkgdir}/usr/lib/python3.8/site-packages/kdj/"
}