summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2020-02-07 16:59:48 +0100
committerLubosz Sarnecki2020-02-07 16:59:48 +0100
commit88ee39a909e4e9576dbaf94a68855e2e48a35051 (patch)
tree51470ab73f01f34ed8028eeeab7b162f36a9f169
downloadaur-88ee39a909e4e9576dbaf94a68855e2e48a35051.tar.gz
Initial commit.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e4655cf6674
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libkate-python3-git
+ pkgdesc = A karaoke and text codec for embedding in ogg. With KateDJ ported to Python 3.
+ pkgver = 0.4.1
+ pkgrel = 6
+ url = https://wiki.xiph.org/OggKate
+ arch = x86_64
+ license = BSD
+ makedepends = pkg-config
+ makedepends = git
+ depends = libpng
+ depends = libogg
+ depends = python3
+ optdepends = wxpython: for KateDJ
+ optdepends = liboggz: for KateDJ
+ provides = libkate=0.4.1
+ conflicts = libkate
+ replaces = libkate
+ source = libkate-python3-git::git+https://gitlab.com/lubosz/kate.git#branch=python3
+ sha512sums = SKIP
+
+pkgname = libkate-python3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..525b95f3a323
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Lubosz Sarnecki <lubosz ! gmail ! com>
+# Arch Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: N30N <archlinux@alunamation.com>
+# Contributor: linkmauve <linkmauve@linkmauve.fr>
+# Contributor: mokkurkalve <xenofil@gmail.com>
+
+pkgname=libkate-python3-git
+pkgver=0.4.1
+pkgrel=6
+pkgdesc="A karaoke and text codec for embedding in ogg. With KateDJ ported to Python 3."
+url="https://wiki.xiph.org/OggKate"
+license=('BSD')
+arch=('x86_64')
+depends=('libpng' 'libogg' 'python3')
+conflicts=('libkate')
+replaces=('libkate')
+provides=('libkate='${pkgver})
+makedepends=('pkg-config' 'git')
+optdepends=('wxpython: for KateDJ'
+ 'liboggz: for KateDJ')
+source=("$pkgname::git+https://gitlab.com/lubosz/kate.git#branch=python3")
+sha512sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ ./autogen.sh
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ export PYTHON="/usr/bin/python3"
+ ./configure --prefix=/usr \
+ --disable-static \
+ --disable-doc
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ python2 -m compileall "${pkgdir}/usr/lib/python3.8/site-packages/kdj/"
+}