summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-11-19 12:32:54 +0100
committerLubosz Sarnecki2015-11-19 12:32:54 +0100
commitb048ee2f4bc7e12fb265fdf8713c9fe5773350ec (patch)
tree312f8189f00772e37e5194d510f3cea1f558624f
parentb510b1a9aa01453f297ac1803d8c38cd31cb2aae (diff)
downloadaur-b048ee2f4bc7e12fb265fdf8713c9fe5773350ec.tar.gz
add correct version. update build patch to git master.
-rw-r--r--.SRCINFO6
-rw-r--r--0001-make-prefix-usr.patch45
-rw-r--r--PKGBUILD18
-rw-r--r--build.patch23
4 files changed, 57 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 394180a89707..a418b18772fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libkeyfinder-git
pkgdesc = Musical key detection for digital audio.
- pkgver = 133.56a9f04
+ pkgver = 2.1.0.227.2f868b2
pkgrel = 1
url = http://www.ibrahimshaath.co.uk/keyfinder/
arch = i686
@@ -14,9 +14,9 @@ pkgbase = libkeyfinder-git
provides = libkeyfinder
conflicts = libkeyfinder
source = git://github.com/ibsh/libKeyFinder.git
- source = build.patch
+ source = 0001-make-prefix-usr.patch
sha256sums = SKIP
- sha256sums = ae4dc6a62290e2efd3ac0c5adc4f9a931567ed3c61d0a7545026e83fbc774a0c
+ sha256sums = 499cc00f55dbe89fe9dde5864ec0121106c00118a0b9f4a87f81fd95495e8c9b
pkgname = libkeyfinder-git
diff --git a/0001-make-prefix-usr.patch b/0001-make-prefix-usr.patch
new file mode 100644
index 000000000000..9b7a7b38b3df
--- /dev/null
+++ b/0001-make-prefix-usr.patch
@@ -0,0 +1,45 @@
+From 2f868b2ffb3140c8d8b27adf7308e26d73271bf7 Mon Sep 17 00:00:00 2001
+From: Lubosz Sarnecki <lubosz.sarnecki@collabora.co.uk>
+Date: Thu, 19 Nov 2015 12:25:32 +0100
+Subject: [PATCH] make prefix /usr/
+
+---
+ LibKeyFinder.pro | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/LibKeyFinder.pro b/LibKeyFinder.pro
+index 3876a58..7d6c86f 100644
+--- a/LibKeyFinder.pro
++++ b/LibKeyFinder.pro
+@@ -34,6 +34,8 @@ QMAKE_CXXFLAGS += -std=c++11
+
+ DEFINES += LIBKEYFINDER_LIBRARY
+
++PREFIX = /usr
++
+ HEADERS += \
+ audiodata.h \
+ binode.h \
+@@ -80,15 +82,15 @@ macx{
+ CONFIG -= ppc ppc64 x86
+ CONFIG += x86_64
+ # installs
+- QMAKE_LFLAGS_SONAME = -Wl,-install_name,/usr/local/lib/
+- headers.path = /usr/local/include/$$TARGET
++ QMAKE_LFLAGS_SONAME = -Wl,-install_name,/usr/lib/
++ headers.path = /usr/include/$$TARGET
+ headers.files = $$HEADERS
+ INSTALLS += headers
+ }
+
+ unix|macx{
+- INCLUDEPATH += /usr/local/include
+- LIBS += -L/usr/local/lib/
++ INCLUDEPATH += /usr/include
++ LIBS += -L/usr/lib/
+ LIBS += -lfftw3
+ }
+
+--
+2.6.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 6ff2650ee8d5..b4892e70de87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_realname=libkeyfinder
pkgname=$_realname-git
-pkgver=133.56a9f04
+pkgver=2.1.0.227.2f868b2
pkgrel=1
pkgdesc="Musical key detection for digital audio."
arch=('i686' 'x86_64')
@@ -15,27 +15,27 @@ conflicts=($_realname)
_gitname=libKeyFinder
-source=("git://github.com/ibsh/libKeyFinder.git" "build.patch")
-sha256sums=("SKIP" 'ae4dc6a62290e2efd3ac0c5adc4f9a931567ed3c61d0a7545026e83fbc774a0c')
-
+source=("git://github.com/ibsh/libKeyFinder.git" "0001-make-prefix-usr.patch")
+sha256sums=("SKIP" '499cc00f55dbe89fe9dde5864ec0121106c00118a0b9f4a87f81fd95495e8c9b')
+
pkgver() {
cd $_gitname
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ VERSION=$(grep VERSION LibKeyFinder.pro | sed 's/VERSION = //')
+ REVISION=$(git rev-list --count master)
+ HASH=$(git rev-parse --short master)
+ echo $VERSION.$REVISION.$HASH
}
build() {
cd $_gitname
- patch -p1 < ../../build.patch
-
+ git am ../../0001-make-prefix-usr.patch
qmake-qt5 PREFIX=/usr
make
}
package() {
cd $_gitname
-
make INSTALL_ROOT="${pkgdir}" install
-
mkdir -p ${pkgdir}/usr/include/keyfinder
cp ${srcdir}/${_gitname}/*.h ${pkgdir}/usr/include/keyfinder
}
diff --git a/build.patch b/build.patch
deleted file mode 100644
index 72461f79876e..000000000000
--- a/build.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/LibKeyFinder.pro b/LibKeyFinder.pro
-index cbb1e8d..07c8c2a 100644
---- a/LibKeyFinder.pro
-+++ b/LibKeyFinder.pro
-@@ -29,6 +29,8 @@ VERSION = 0.2.2
-
- DEFINES += LIBKEYFINDER_LIBRARY
-
-+PREFIX = /usr
-+
- HEADERS += \
- keyfinder.h \
- chromagram.h \
-@@ -114,7 +116,7 @@ unix:!symbian {
- maemo5 {
- target.path = /opt/usr/lib
- } else {
-- target.path = /usr/local/lib
-+ target.path = /usr/lib
- }
- INSTALLS += target
- }
-