summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Mesa2017-06-22 18:53:31 -0500
committerSamuel Mesa2017-06-22 18:53:31 -0500
commit810c7875f1c89992cdeb89d5397a46dfafbe0247 (patch)
treee7efba1c113309fb5283b029112305fe9e272bfe
parentedaa4cb73dee567af2e7ff8d4b496ad4fddde50d (diff)
downloadaur-810c7875f1c89992cdeb89d5397a46dfafbe0247.tar.gz
Update to version 1.3.0 and change repository
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD57
2 files changed, 44 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ca5a4791239..527bef5d3bf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = libkml
pkgdesc = A KML library written in C++ with bindings to other languages
- pkgver = 1.2.0
- pkgrel = 3
- url = https://github.com/google/libkml
+ pkgver = 1.3.0
+ pkgrel = 0
+ url = https://github.com/libkml/libkml
arch = i686
arch = x86_64
license = BSD
+ makedepends = cmake
+ makedepends = swig
depends = expat
depends = uriparser
optdepends = swig: bindings for additional languages
optdepends = python2: python bindings
- optdepends = jdk: java bindings
conflicts = libminizip
- source = https://github.com/kubark42/libkml/archive/master.zip
- md5sums = e5cae2b9ee6a652897a1f6e92fb094a4
+ source = https://github.com/libkml/libkml/archive/1.3.0.tar.gz
+ md5sums = e663141e9ebd480538b25d226e1b2979
pkgname = libkml
diff --git a/PKGBUILD b/PKGBUILD
index 2eea70c842f3..4bff8d465f9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,59 @@
# Maintainer: Samuel Mesa <samuelmesa@linuxmail.org>
pkgname=libkml
-pkgver=1.2.0
-pkgrel=3
+pkgver=1.3.0
+pkgrel=0
pkgdesc="A KML library written in C++ with bindings to other languages"
arch=(i686 x86_64)
-url="https://github.com/google/libkml"
+url="https://github.com/libkml/libkml"
license=('BSD')
depends=('expat' 'uriparser')
optdepends=('swig: bindings for additional languages'
- 'python2: python bindings'
- 'jdk: java bindings')
+ 'python2: python bindings')
+makedepends=('cmake' 'swig')
# TODO: Use existing libminizip package instead of conflicting with it.
conflicts=('libminizip')
-source=("https://github.com/kubark42/${pkgname}/archive/master.zip")
-md5sums=('e5cae2b9ee6a652897a1f6e92fb094a4')
+source=("https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('e663141e9ebd480538b25d226e1b2979')
build() {
- cd "$srcdir/${pkgname}-master"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ if [ -f CMakeCache.txt ]
+ then
+ rm -rf CMakeCache.txt CMakeFiles
+ fi
+ rm -rf build && mkdir build
+ cd build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_SWIG=ON \
+ -DWITH_PYTHON=ON \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_LIBRARIES=/usr/lib/python2.7 \
+ -DPYTHON_INCLUDE_PATH=/usr/include/python2.7 \
+ -DBUILD_EXAMPLES=OFF
# Add --disable-python or --disable-java to configure flags if your
# system doesn't have corresponding language.
- ./autogen.sh
-
- ./configure --prefix=/usr --enable-systempython \
- --with-python-include-dir=/usr/include/python2.7 \
- --with-python-lib-dir=/usr/lib/python2.7
- make -j5
+ make clean
+ make -j2
}
package() {
- cd "$srcdir/${pkgname}-master"
- make DESTDIR="$pkgdir/" install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cd build
+
+ make || return 1
+ make DESTDIR=${pkgdir} install
+
# TODO: Remove uriparser sources before building and use existing package.
- rm "$pkgdir/usr/lib/liburiparser."{{,l}a,so{,.1{,.0.5}}}
- rm "$pkgdir/usr/lib/libminizip."{{,l}a,so{,.0}}
- mkdir -p "$pkgdir/share/licenses/$pkgname"
- cp COPYING "$pkgdir/share/licenses/$pkgname/"
+ #rm "${pkgdir}/usr/lib/liburiparser."{{,l}a,so{,.1{,.0.5}}}
+ #rm "${pkgdir}/usr/lib/libminizip."{{,l}a,so{,.0}}
+ #mkdir -p "${pkgdir}/share/licenses/${pkgname}"
+ #cp COPYING "${pkgdir}/share/licenses/${pkgname}/"
}