summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSándor Nagy2015-06-20 22:45:54 +0200
committerSándor Nagy2015-06-20 22:45:54 +0200
commit5ba7af7eda485601e6ecb1fe53754bf9237f200c (patch)
tree6eda964b276cddee348a461fc8f795be8bcdf5d1
downloadaur-5ba7af7eda485601e6ecb1fe53754bf9237f200c.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54e61324ac20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libkomparediff2-git
+ pkgdesc = Library to compare files and strings. (GIT version)
+ pkgver = r263.1e58d07
+ pkgrel = 1
+ url = https://projects.kde.org/projects/kde/kdesdk/libkomparediff2
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = FDL
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ makedepends = git
+ makedepends = cmake
+ depends = kio
+ provides = libkomparediff2
+ conflicts = libkomparediff2
+ source = git://anongit.kde.org/libkomparediff2
+ sha1sums = SKIP
+
+pkgname = libkomparediff2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28db1134dcda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Sándor Nagy <sanya868 at gmail dot com>
+# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: mosra <mosra@centrum.cz>
+
+pkgname=libkomparediff2-git
+pkgver=r263.1e58d07
+pkgrel=1
+pkgdesc="Library to compare files and strings. (GIT version)"
+url='https://projects.kde.org/projects/kde/kdesdk/libkomparediff2'
+arch=('i686' 'x86_64')
+license=('GPL' 'LGPL' 'FDL')
+depends=('kio')
+makedepends=('extra-cmake-modules' 'kdoctools' 'git' 'cmake')
+conflicts=('libkomparediff2')
+provides=('libkomparediff2')
+source=("git://anongit.kde.org/libkomparediff2")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd libkomparediff2
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ cmake ../libkomparediff2 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}