summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-08 22:07:59 -0500
committerVincent Grande2021-01-08 22:07:59 -0500
commita8ff39e06a06d6bcb77b55cf84842227fd81d1c5 (patch)
tree5bde991a770836063292309b0d16aec07c54906c
downloadaur-a8ff39e06a06d6bcb77b55cf84842227fd81d1c5.tar.gz
initial upload
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c23a06de2a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libksba-git
+ pkgdesc = Library for working with X.509 certificates, CMS data and related objects
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://www.gnupg.org/related_software/libksba/
+ arch = x86_64
+ license = GPL
+ depends = bash
+ depends = libgpg-error
+ depends = glibc
+ provides = libksba
+ conflicts = libksba
+ source = git://git.gnupg.org/libksba.git
+ sha256sums = SKIP
+
+pkgname = libksba-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efc6517bc9ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Vincent Grande <shoobe420@gmail.com>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
+
+pkgname=libksba-git
+pkgver=1.4.0
+pkgrel=1
+pkgdesc='Library for working with X.509 certificates, CMS data and related objects'
+url='https://www.gnupg.org/related_software/libksba/'
+license=('GPL')
+arch=('x86_64')
+depends=('bash' 'libgpg-error' 'glibc')
+provides=(libksba)
+conflicts=(libksba)
+source=(git://git.gnupg.org/libksba.git)
+sha256sums=('SKIP')
+#validpgpkeys=('D8692123C4065DEA5E0F3AB5249B39D24F25E3B6') # Werner Koch
+
+pkgver() {
+ cd libksba
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ cd libksba
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+#check() {
+# cd libksba
+# make check
+#}
+
+package() {
+ cd libksba
+ make DESTDIR="${pkgdir}" install
+}