summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBas Timmer2021-06-10 17:14:19 +0200
committerBas Timmer2021-06-10 17:14:19 +0200
commite7590fd01ebc08e5e0f5de4fd311fff7a267d1fb (patch)
treeb43a91efa086e50ea3e592f8b60f02c3d72bfae4
parent73852ea5319f1ad254ea021af81b7fcc8e8ead75 (diff)
downloadaur-e7590fd01ebc08e5e0f5de4fd311fff7a267d1fb.tar.gz
Plasma 5.22.0 + Fix network monitor applet
-rw-r--r--PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37c53185f6ce..b70ac4e6f43e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,36 @@
_pkgname=libksysguard
pkgname=libksysguard-light
-pkgver=5.21.5
-pkgrel=1
+pkgver=5.22.0
+pkgrel=2
pkgdesc='Libraries for ksysguard to retrieve information on the current status of computer hardware without the big dependency on qt5-webengine'
arch=(x86_64)
url=' https://kde.org/plasma-desktop/'
license=(LGPL)
-depends=(libxres knewstuff kdeclarative)
+depends=(libxres kdeclarative knewstuff)
makedepends=(extra-cmake-modules kdoctools qt5-tools)
+conflicts=(libksysguard 'ksysguard<5.21.90')
groups=(plasma)
-conflicts=(libksysguard)
replaces=(libksysguard)
provides=(libksysguard)
-source=(https://download.kde.org/stable/plasma/$pkgver/$_pkgname-$pkgver.tar.xz{,.sig})
-sha256sums=('5ff8c687a9d245d28ec4b92c019d2234cd931796c619ebb096de6e49cd18ebe8'
- 'SKIP')
+source=(https://download.kde.org/stable/plasma/$pkgver/$_pkgname-$pkgver.tar.xz{,.sig}
+ https://invent.kde.org/plasma/libksysguard/-/commit/9dc314d8.patch)
+install=libksysguard.install
+sha256sums=('a2d3973aaf7d5c4a1cb6dd463ec8183dd4e9a6c6b851df4b8824f8dd562607a9'
+ 'SKIP'
+ '2e0ddf9cc5c9aa52e8f559100543148ceec9c7aaacdb64b49fe54827a94d2f1d')
validpgpkeys=('2D1D5B0588357787DE9EE225EC94D18F7F05997E' # Jonathan Riddell <jr@jriddell.org>
'0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D' # Bhushan Shah <bshah@kde.org>
'D07BD8662C56CB291B316EB2F5675605C74E02CF' # David Edmundson <davidedmundson@kde.org>
'1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
+prepare() {
+ patch -d $_pkgname-$pkgver -p1 < 9dc314d8.patch # Fix network monitor applet
+}
+
build() {
cmake -B build -S $_pkgname-$pkgver \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib \
-DBUILD_TESTING=OFF
cmake --build build
}