summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciej Sieczka2017-10-29 14:44:49 +0100
committerMaciej Sieczka2017-10-29 14:44:49 +0100
commitfeb56d09908165637a8ba1279878c8548f159929 (patch)
tree548687114b5325823e1f7fa6d06b95863d1f37db
downloadaur-feb56d09908165637a8ba1279878c8548f159929.tar.gz
Initial.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c75c6f4854e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Oct 29 13:38:28 UTC 2017
+pkgbase = python-liblas
+ pkgdesc = Python bindings for libLAS - a C/C++ library for reading and writing LAS LiDAR format.
+ pkgver = 1.8.1
+ pkgrel = 1
+ url = https://liblas.org
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ options = !emptydirs
+ source = https://pypi.python.org/packages/2f/13/1d233142092b9dcfbfd47ec9f3380361e5a7b9061408a809005abe0e60aa/libLAS-1.8.1.tar.gz
+ md5sums = 93921e0c37d47b03eea8529aa31d9073
+
+pkgname = python-liblas
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a25a3a85d40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Maciej Sieczka <msieczka at sieczka dot org>
+
+pkgname='python-liblas'
+pkgver='1.8.1'
+pkgrel='1'
+pkgdesc='Python bindings for libLAS - a C/C++ library for reading and writing LAS LiDAR format.'
+arch=('any')
+depends=('python')
+makedepends=('python-setuptools')
+url='https://liblas.org'
+license=('BSD')
+options=('!emptydirs')
+source=("https://pypi.python.org/packages/2f/13/1d233142092b9dcfbfd47ec9f3380361e5a7b9061408a809005abe0e60aa/libLAS-${pkgver}.tar.gz")
+md5sums=('93921e0c37d47b03eea8529aa31d9073')
+
+build() {
+ cd "$srcdir/libLAS-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/libLAS-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}