summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weißschuh2022-09-30 08:37:27 +0200
committerThomas Weißschuh2022-09-30 08:37:27 +0200
commit972d38a971f4b03f50834ffce239a24b986b1c50 (patch)
tree66945d944745f6e0a58ce659ee00dfe6973ecb60
downloadaur-972d38a971f4b03f50834ffce239a24b986b1c50.tar.gz
Initial upload: liblc3 1.0.0-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d9f565500e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = liblc3
+ pkgdesc = Low Complexity Communication Codec
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/google/liblc3
+ arch = x86_64
+ license = Apache
+ makedepends = meson
+ source = liblc3-1.0.0.tar.gz::https://github.com/google/liblc3/archive/refs/tags/v1.0.0.tar.gz
+ sha256sums = bc819ba37ce6f932f0c4c9aadeab21904e73eeecc36bf288f1b01857d37b856f
+
+pkgname = liblc3
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f00dfb404be1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Thomas Weißschuh <thomas t-8ch de>
+
+pkgname=liblc3
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Low Complexity Communication Codec"
+arch=(x86_64)
+url="https://github.com/google/liblc3"
+license=('Apache')
+depends=()
+makedepends=(meson)
+checkdepends=()
+optdepends=()
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/google/liblc3/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('bc819ba37ce6f932f0c4c9aadeab21904e73eeecc36bf288f1b01857d37b856f')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ rm -r build
+ arch-meson build -Dtools=true
+ meson compile -C build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ meson install --destdir "$pkgdir" -C build
+ install -D -t "$pkgdir/usr/bin" build/tools/{elc3,dlc3}
+}