summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid P2020-07-23 01:09:38 -0400
committerDavid P2020-07-23 01:09:38 -0400
commit6da3177a4452461fbfc926509ec90c40be32e0a3 (patch)
tree937cb5256ac03fde728b4ce707007f4383929e17
downloadaur-6da3177a4452461fbfc926509ec90c40be32e0a3.tar.gz
upgpkg: liblinphone 4.4.0-1
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD33
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94e5e0b64f12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = liblinphone
+ pkgdesc = A high-level SIP library
+ pkgver = 4.4.0
+ pkgrel = 1
+ url = http://www.linphone.org
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = cmake
+ makedepends = doxygen
+ makedepends = graphviz
+ makedepends = python-pystache
+ makedepends = python-sphinx
+ makedepends = xsd
+ depends = belcard
+ depends = belle-sip
+ depends = mediastreamer
+ depends = soci
+ depends = xerces-c
+ depends = lime
+ source = https://gitlab.linphone.org/BC/public/liblinphone/-/archive/4.4.0/liblinphone-4.4.0.tar.gz
+ sha256sums = a9a468e7e15ad59062d6460b7d2f6b1f1cd74c15d54a7b5dae6bad28a489cf40
+
+pkgname = liblinphone
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2162e1e5267
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: David P. <megver83@parabola.nu>
+
+pkgname=liblinphone
+pkgver=4.4.0
+pkgrel=1
+pkgdesc='A high-level SIP library'
+arch=(x86_64 i686)
+url='http://www.linphone.org'
+license=('GPL')
+depends=(belcard belle-sip mediastreamer soci xerces-c lime)
+makedepends=(cmake doxygen graphviz python-pystache python-sphinx xsd)
+source=("https://gitlab.linphone.org/BC/public/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('a9a468e7e15ad59062d6460b7d2f6b1f1cd74c15d54a7b5dae6bad28a489cf40')
+
+build() {
+ cd "$pkgname-$pkgver"
+ CXXFLAGS="$CXXFLAGS -Wno-deprecated -Wimplicit-fallthrough=0 -Wno-unused-function"
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_STATIC=NO \
+ -DENABLE_CXX_WRAPPER=YES \
+ -DENABLE_DOC=NO \
+ -DENABLE_LIME=YES \
+ -DENABLE_UNIT_TESTS=NO \
+ -DENABLE_STRICT=NO \
+ -DCMAKE_INSTALL_RPATH=NO .
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}