summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-10-14 21:25:03 -0400
committerGuillaume Horel2017-10-14 21:25:03 -0400
commit7f5b5b87f769f8458ad0da255e451205f0da5a98 (patch)
tree8c4414a89f8c1d69401f084ddc12b53cb5e1452c
parentf2c269f672ba9162df20bb5e0817450f403d4e34 (diff)
downloadaur-7f5b5b87f769f8458ad0da255e451205f0da5a98.tar.gz
version bump
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD62
-rw-r--r--linphone.install8
3 files changed, 66 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c4bdbe6ad9d..6e7d63b1a177 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,36 @@
pkgbase = linphone-git
- pkgdesc = Linphone is an internet phone or Voice Over IP phone (VoIP).
- pkgver = 3.7.0.r1376.gbe7413c
+ pkgdesc = A Voice-over-IP phone
+ pkgver = 3.12.0.r226.g8d4d87548
pkgrel = 1
- url = http://www.linphone.org/
+ url = http://www.linphone.org
+ install = linphone.install
arch = i686
arch = x86_64
- license = GPL2
- makedepends = git
- depends = gtk2
+ license = GPL
+ makedepends = cmake
+ makedepends = pkg-config
+ makedepends = python-pystache
+ makedepends = perl-xml-parser
+ makedepends = intltool
+ depends = alsa-lib
+ depends = ffmpeg
+ depends = speex
+ depends = libv4l
+ depends = v4l-utils
+ depends = libpulse
+ depends = libxv
depends = mediastreamer-git
- depends = libexosip2
+ depends = ortp-git
+ depends = bzrtp-git
+ depends = bcg729
+ depends = libsoup
depends = belle-sip-git
+ depends = libnotify
+ optdepends = pulseaudio
provides = linphone
conflicts = linphone
- options = !libtool
- source = git://git.linphone.org/linphone.git
+ options = !emptydirs
+ source = git+https://github.com/BelledonneCommunications/linphone.git#commit=8d4d875486e7263354c12dedb3a3b589c52a9bda
sha256sums = SKIP
pkgname = linphone-git
diff --git a/PKGBUILD b/PKGBUILD
index a3c81b7488ac..058d9f50ef34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,44 @@
-pkgname="linphone-git"
-_basename="linphone"
-pkgver=3.7.0.r1376.gbe7413c
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Darwin Bautista <djclue917@gmail.com>
+# Contributor: Mark Lee <mark@markelee.com>
+
+pkgname=linphone-git
+_pkgname=linphone
+pkgver=3.12.0.r226.g8d4d87548
pkgrel=1
-pkgdesc="Linphone is an internet phone or Voice Over IP phone (VoIP)."
-arch=(i686 x86_64)
-url="http://www.linphone.org/"
-license=('GPL2')
-depends=('gtk2' 'mediastreamer-git' 'libexosip2' 'belle-sip-git')
-makedepends=('git')
-options=(!libtool)
-provides=("${_basename}")
-conflicts=("${_basename}")
-source=("git://git.${_basename}.org/${_basename}.git")
+pkgdesc="A Voice-over-IP phone"
+arch=('i686' 'x86_64')
+url="http://www.linphone.org"
+license=('GPL')
+depends=('alsa-lib' 'ffmpeg' 'speex' 'libv4l' 'v4l-utils'
+ 'libpulse' 'libxv' 'mediastreamer-git' 'ortp-git' 'bzrtp-git'
+ 'bcg729' 'libsoup' 'belle-sip-git' 'libnotify')
+makedepends=('cmake' 'pkg-config' 'python-pystache' 'perl-xml-parser' 'intltool')
+optdepends=('pulseaudio')
+options=('!emptydirs')
+provides=('linphone')
+conflicts=('linphone')
+install=linphone.install
+source=("git+https://github.com/BelledonneCommunications/linphone.git#commit=8d4d875486e7263354c12dedb3a3b589c52a9bda")
sha256sums=('SKIP')
-prepare() {
- cd "$_basename"
- mkdir -p oRTP mediastreamer2
- touch oRTP/autogen.sh mediastreamer2/autogen.sh
- chmod +x oRTP/autogen.sh mediastreamer2/autogen.sh
-
- ./autogen.sh
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
}
build() {
- cd "$_basename"
- ./configure --prefix=/usr --enable-external-ortp --enable-external-mediastreamer
+ cd $_pkgname
+ CXXFLAGS="$CXXFLAGS -Wno-deprecated -Wimplicit-fallthrough=0 -Wno-unused-function"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DENABLE_STATIC=NO \
+ -DENABLE_CXX_WRAPPER=YES .
make
}
package() {
- cd "$_basename"
- make DESTDIR=$pkgdir install
-}
-
-pkgver() {
- cd "$_basename"
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir" install
}
diff --git a/linphone.install b/linphone.install
new file mode 100644
index 000000000000..0470a3842e47
--- /dev/null
+++ b/linphone.install
@@ -0,0 +1,8 @@
+post_install() {
+ post_upgrade
+}
+
+post_upgrade() {
+ echo "-- Probably you need notification daemon running"
+ echo "-- See https://wiki.archlinux.org/index.php/Desktop_notifications"
+}