summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-09-09 22:07:57 -0400
committerGuillaume Horel2020-09-09 22:08:04 -0400
commitc119ead6fa9a6e6a7112f1dd58241f656c4437ed (patch)
tree0e88a4e05a72832b013d4803b6a0a43a70650a18
parent4328ba774bcf95ed66ec9dc83f7876f9923b5274 (diff)
downloadaur-c119ead6fa9a6e6a7112f1dd58241f656c4437ed.tar.gz
rename package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 489046a72a04..dad4f190a326 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = linphone-git
+pkgbase = liblinphone-git
pkgdesc = A Voice-over-IP phone library and CLI
- pkgver = 4.4.0.alpha.r106.gcd9a2477e
+ pkgver = 4.5.0.alpha.r112.g868bee338
pkgrel = 1
url = http://www.linphone.org
install = linphone.install
@@ -12,29 +12,21 @@ pkgbase = linphone-git
makedepends = graphviz
makedepends = python-pystache
makedepends = xsd
- depends = alsa-lib
- depends = bctoolbox>=4.3
depends = belcard>=4.3
depends = belle-sip>=4.3
- depends = belr>=4.3
depends = bzrtp>=4.3
depends = ffmpeg
depends = lime>=4.3
- depends = libpulse
- depends = libv4l
- depends = libxv
depends = mediastreamer>=4.4.0
depends = ortp>=4.4.0
depends = soci>=4.0
- depends = speex
- depends = v4l-utils
depends = xerces-c
optdepends = pulseaudio
- provides = linphone=4.4.0.alpha.r106.gcd9a2477e
- conflicts = linphone
+ provides = liblinphone=4.5.0.alpha.r112.g868bee338
+ conflicts = liblinphone
options = !emptydirs
source = git+https://github.com/BelledonneCommunications/linphone.git
sha256sums = SKIP
-pkgname = linphone-git
+pkgname = liblinphone-git
diff --git a/PKGBUILD b/PKGBUILD
index 6b969b1bad66..4d83746429b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,27 @@
# Contributor: Darwin Bautista <djclue917@gmail.com>
# Contributor: Mark Lee <mark@markelee.com>
-pkgname=linphone-git
+pkgname=liblinphone-git
_pkgname=linphone
-pkgver=4.4.0.alpha.r106.gcd9a2477e
+pkgver=4.5.0.alpha.r112.g868bee338
pkgrel=1
pkgdesc="A Voice-over-IP phone library and CLI"
arch=('x86_64')
url="http://www.linphone.org"
license=('GPL')
-depends=('alsa-lib' 'bctoolbox>=4.3' 'belcard>=4.3' 'belle-sip>=4.3' 'belr>=4.3'
- 'bzrtp>=4.3' 'ffmpeg' 'lime>=4.3' 'libpulse' 'libv4l'
- 'libxv' 'mediastreamer>=4.4.0' 'ortp>=4.4.0' 'soci>=4.0' 'speex' 'v4l-utils' 'xerces-c')
+depends=('belcard>=4.3' 'belle-sip>=4.3' 'bzrtp>=4.3' 'ffmpeg' 'lime>=4.3'
+ 'mediastreamer>=4.4.0' 'ortp>=4.4.0' 'soci>=4.0' 'xerces-c')
makedepends=('cmake' 'doxygen' 'git' 'graphviz' 'python-pystache' 'xsd')
optdepends=('pulseaudio')
options=('!emptydirs')
-provides=("linphone=$pkgver")
-conflicts=('linphone')
+provides=("liblinphone=$pkgver")
+conflicts=('liblinphone')
install=linphone.install
source=("git+https://github.com/BelledonneCommunications/linphone.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "${_pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
}