summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-10-16 16:21:25 -0400
committerGuillaume Horel2017-10-16 16:21:25 -0400
commitca2bd7b68909459af8e5593c587887c624b97597 (patch)
treee3828519a77d6226b84a3d56e190635f2a290b12
parentfdc9ea17fdd729f8df4716bf24d47e6bcab24168 (diff)
downloadaur-ca2bd7b68909459af8e5593c587887c624b97597.tar.gz
update dependencies
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 236b43077596..82b7b2a38332 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = linphone-git
arch = x86_64
license = GPL
makedepends = cmake
+ makedepends = doxygen
makedepends = pkg-config
makedepends = python-pystache
makedepends = perl-xml-parser
diff --git a/PKGBUILD b/PKGBUILD
index 87598f76c274..692ab57ea27d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ license=('GPL')
depends=('alsa-lib' 'ffmpeg' 'speex' 'libv4l' 'v4l-utils'
'libpulse' 'libxv' 'bctoolbox-git' 'belle-sip-git' 'belcard-git' 'belr-git' 'bzrtp-git'
'mediastreamer-git' 'ortp-git' 'libsoup' 'belle-sip-git' 'libnotify')
-makedepends=('cmake' 'pkg-config' 'python-pystache' 'perl-xml-parser' 'intltool')
+makedepends=('cmake' 'doxygen' 'pkg-config' 'python-pystache' 'perl-xml-parser' 'intltool')
optdepends=('pulseaudio')
options=('!emptydirs')
provides=('linphone')
@@ -34,7 +34,10 @@ build() {
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DENABLE_STATIC=NO \
- -DENABLE_CXX_WRAPPER=YES .
+ -DENABLE_CXX_WRAPPER=YES \
+ -DENABLE_ROOTCA_DOWNLOAD=NO \
+ -DENABLE_LIME=YES \
+ -DENABLE_UNIT_TESTS=NO .
make
}