summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-12-19 16:47:12 -0500
committerGuillaume Horel2020-12-19 16:47:12 -0500
commitd0205dc65b6a1d705b22a488ab6599bcec53ffa2 (patch)
treec8f9819f0b1e42d32396fb890ed1040b6ce6d605
parentc119ead6fa9a6e6a7112f1dd58241f656c4437ed (diff)
downloadaur-d0205dc65b6a1d705b22a488ab6599bcec53ffa2.tar.gz
cleanup
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 23 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dad4f190a326..107b3818c57f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = liblinphone-git
pkgdesc = A Voice-over-IP phone library and CLI
- pkgver = 4.5.0.alpha.r112.g868bee338
+ pkgver = 4.5.0.alpha.r300.gf78f649e3
pkgrel = 1
url = http://www.linphone.org
install = linphone.install
@@ -12,17 +12,16 @@ pkgbase = liblinphone-git
makedepends = graphviz
makedepends = python-pystache
makedepends = xsd
- depends = belcard>=4.3
- depends = belle-sip>=4.3
- depends = bzrtp>=4.3
+ depends = belcard>=4.4
+ depends = belle-sip>=4.5
+ depends = bzrtp>=4.4
depends = ffmpeg
- depends = lime>=4.3
+ depends = lime>=4.4
depends = mediastreamer>=4.4.0
- depends = ortp>=4.4.0
- depends = soci>=4.0
+ depends = ortp>=4.5
depends = xerces-c
optdepends = pulseaudio
- provides = liblinphone=4.5.0.alpha.r112.g868bee338
+ provides = liblinphone=4.5.0.alpha.r300.gf78f649e3
conflicts = liblinphone
options = !emptydirs
source = git+https://github.com/BelledonneCommunications/linphone.git
diff --git a/PKGBUILD b/PKGBUILD
index 4d83746429b2..8c3042e9dfd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
pkgname=liblinphone-git
_pkgname=linphone
-pkgver=4.5.0.alpha.r112.g868bee338
+pkgver=4.5.0.alpha.r300.gf78f649e3
pkgrel=1
pkgdesc="A Voice-over-IP phone library and CLI"
arch=('x86_64')
url="http://www.linphone.org"
license=('GPL')
-depends=('belcard>=4.3' 'belle-sip>=4.3' 'bzrtp>=4.3' 'ffmpeg' 'lime>=4.3'
- 'mediastreamer>=4.4.0' 'ortp>=4.4.0' 'soci>=4.0' 'xerces-c')
+depends=('belcard>=4.4' 'belle-sip>=4.5' 'bzrtp>=4.4' 'ffmpeg' 'lime>=4.4'
+ 'mediastreamer>=4.4.0' 'ortp>=4.5' 'xerces-c')
makedepends=('cmake' 'doxygen' 'git' 'graphviz' 'python-pystache' 'xsd')
optdepends=('pulseaudio')
options=('!emptydirs')
@@ -28,20 +28,20 @@ pkgver() {
}
build() {
- cd $_pkgname
- CXXFLAGS="$CXXFLAGS -Wno-deprecated -Wimplicit-fallthrough=0 -Wno-unused-function"
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_STATIC=NO \
- -DENABLE_CXX_WRAPPER=YES \
- -DENABLE_DOC=NO \
- -DENABLE_LIME=YES \
- -DENABLE_UNIT_TESTS=NO \
- -DENABLE_STRICT=NO \
- -DCMAKE_INSTALL_RPATH=NO .
- make
+ cmake -B build $_pkgname \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_STATIC=NO \
+ -DENABLE_CXX_WRAPPER=YES \
+ -DENABLE_DOC=NO \
+ -DENABLE_LIME=NO \
+ -DENABLE_LIME_X3DH=YES \
+ -DENABLE_UNIT_TESTS=NO \
+ -DENABLE_STRICT=NO \
+ -DCMAKE_INSTALL_RPATH=NO \
+ -Wno-dev
+ make -C build
}
package() {
- cd "$_pkgname"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" -C build install
}