summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpyros Stathopoulos2015-06-13 13:49:48 +0300
committerSpyros Stathopoulos2015-06-13 13:49:48 +0300
commit84143bd14f568abbc7671025fd92f27adcb28ce2 (patch)
tree2f174c38c2648dda61fb48e6d4f62e4a07cb6790
downloadaur-84143bd14f568abbc7671025fd92f27adcb28ce2.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD40
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..385952882232
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libljacklm
+ pkgdesc = Linux high level LabJack U12 driver
+ pkgver = 2013.05
+ pkgrel = 1
+ url = http://labjack.com/support/u12/ljacklm
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = labjack-exodriver
+ provides = ljacklm
+ conflicts = ljacklm
+ source = http://labjack.com/sites/default/files/2013/05/ljacklm.zip
+ source = LICENSE
+ md5sums = 3fd8a47d058854d722ab24cd7a17d031
+ md5sums = 6b654d05134aa959b7db1f4b05c7f33d
+
+pkgname = libljacklm
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..995bbc514134
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg/*
+src/*
+*.tar.gz
+*.tar.xz
+*.tar.bz2
+*.zip
+*.swp
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..890ac66e7465
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,23 @@
+LICENSE
+
+All exodriver library and example source code are licensed under MIT X11.
+
+ Copyright (c) 2009 LabJack Corporation <support@labjack.com>
+
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+
+ The above copyright notice and this permission notice shall be included in
+ all copies or substantial portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+ THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b296c67ac13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Spyros Stathopoulos <foucault.online@gmail.com>
+pkgname=libljacklm
+pkgver=2013.05
+pkgrel=1
+pkgdesc="Linux high level LabJack U12 driver"
+arch=('i686' 'x86_64')
+url="http://labjack.com/support/u12/ljacklm"
+license=('MIT')
+depends=("labjack-exodriver")
+provides=('ljacklm')
+conflicts=('ljacklm')
+source=("http://labjack.com/sites/default/files/2013/05/ljacklm.zip"
+ "LICENSE")
+md5sums=('3fd8a47d058854d722ab24cd7a17d031'
+ '6b654d05134aa959b7db1f4b05c7f33d')
+
+build() {
+ cd "${srcdir}"/ljacklm/"${pkgname}"
+ sed -i -e 's:/usr/local/:/usr/:g' Makefile
+ make
+ ln -s libljacklm.so.* libljacklm.so
+
+}
+
+package() {
+ cd "$srcdir/ljacklm/"
+ mkdir -p ${pkgdir}/usr/lib
+ mkdir -p ${pkgdir}/usr/include
+ mkdir -p ${pkgdir}/usr/share/doc/libljacklm
+ install -D -m755 ${pkgname}/libljacklm.so.* ${pkgdir}/usr/lib/
+ cp -dpr --no-preserve=ownership \
+ libljacklm/libljacklm.so ${pkgdir}/usr/lib/libljacklm.so
+ install -D -m644 libljacklm/ljacklm.h ${pkgdir}/usr/include/
+ install -D -m644 ../LICENSE \
+ ${pkgdir}/usr/share/licenses/libljacklm/LICENSE
+ cp -dpr --no-preserve=ownership \
+ examples ${pkgdir}/usr/share/doc/libljacklm
+}
+
+# vim:set ts=2 sw=2 et: