summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Kalb2016-10-31 16:47:59 +0100
committerMarkus Kalb2016-10-31 16:47:59 +0100
commit040a3f69c461d094f988f8f069e6d865488f1e14 (patch)
treeb800a35558e5a06c27b098a9ff209245ef8371a9
downloadaur-040a3f69c461d094f988f8f069e6d865488f1e14.tar.gz
Initial Version
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc45e3eef274
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Oct 31 15:26:14 UTC 2016
+pkgbase = liblocked-sstream-git
+ pkgdesc = library for dcpomatic sstream locking
+ pkgver = 0.r4.22163e0
+ pkgrel = 1
+ url = https://github.com/cth103/locked_sstream.git
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = python2
+ makedepends = boost>=1.45
+ depends = boost-libs>=1.45
+ provides = liblocked-sstream
+ conflicts = liblocked-sstream
+ source = liblocked-sstream-git::git+https://github.com/cth103/locked_sstream.git
+ sha512sums = SKIP
+
+pkgname = liblocked-sstream-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bee29d5bf28e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Markus Kalb <mk@filmkreis.tu-darmstadt.de>
+# Contributor: Stefan Karner <stefan.karner@student.tuwien.ac.at>
+pkgname=liblocked-sstream-git
+pkgver=0.r4.22163e0
+pkgrel=1
+pkgdesc="library for dcpomatic sstream locking"
+arch=('i686' 'x86_64')
+url="https://github.com/cth103/locked_sstream.git"
+license=('GPL')
+depends=('boost-libs>=1.45')
+makedepends=('python2' 'boost>=1.45')
+provides=('liblocked-sstream')
+conflicts=('liblocked-sstream')
+#source=("libsub-git::git+https://github.com/cth103/libsub.git#branch=1.0")
+source=("liblocked-sstream-git::git+https://github.com/cth103/locked_sstream.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd liblocked-sstream-git
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ CXXFLAGS="$CXXFLAGS -std=c++11"
+ cd liblocked-sstream-git
+ python2 waf configure --prefix=/usr
+ python2 waf build
+}
+
+package() {
+ cd liblocked-sstream-git
+ python2 waf install --destdir=$pkgdir
+}