summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Lau2016-01-09 15:34:50 +0100
committerSebastian Lau2016-01-09 15:34:50 +0100
commitd493b4ce7e8d588eb8f61a93bd448125b40d845c (patch)
tree9913ce5fcac18eee9c8342106d36738785626cc3
parent536d0951d68d851d3e2e431257a5654c7f61c9c4 (diff)
downloadaur-d493b4ce7e8d588eb8f61a93bd448125b40d845c.tar.gz
Update to 1.7.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23670e7253a9..f67cf12079e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jan 7 23:58:33 UTC 2016
+# Sat Jan 9 14:34:34 UTC 2016
pkgbase = liblogcpp
pkgdesc = A simple, but highly customizable and intuitive LGPL library for logging in C++.
- pkgver = 1.7.0
+ pkgver = 1.7.1
pkgrel = 1
url = https://github.com/nullptrT/liblogcpp
arch = x86_64
@@ -11,8 +11,8 @@ pkgbase = liblogcpp
license = LGPL2.1
makedepends = cmake
makedepends = qt5-base
- source = liblogcpp-1.7.0.tar.gz::https://github.com/nullptrT/liblogcpp/archive/1.7.0.tar.gz
- md5sums = 1d86b9cbb57d1e8f055bb0f4a3521ee4
+ source = liblogcpp-1.7.1.tar.gz::https://github.com/nullptrT/liblogcpp/archive/1.7.1.tar.gz
+ md5sums = fac9d7642172476a24da79f0e6f87cf9
pkgname = liblogcpp
diff --git a/PKGBUILD b/PKGBUILD
index 951fb13f8563..8824a5834441 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Sebastian Lau <arch _at_ slau _dot_ info>
pkgname="liblogcpp"
-pkgver=1.7.0
+pkgver=1.7.1
pkgrel=1
pkgdesc="A simple, but highly customizable and intuitive LGPL library for logging in C++."
arch=('x86_64' 'i386' 'arm6h')
@@ -9,13 +9,17 @@ license=('LGPL2.1')
depends=()
makedepends=('cmake' 'qt5-base')
source=("$pkgname-$pkgver.tar.gz::https://github.com/nullptrT/$pkgname/archive/$pkgver.tar.gz")
-md5sums=('1d86b9cbb57d1e8f055bb0f4a3521ee4')
+md5sums=('fac9d7642172476a24da79f0e6f87cf9')
-build() {
+prepare() {
cd "$srcdir"
+ [[ -e build ]] && rm -r build
mkdir build
- cd build
+}
+
+build() {
+ cd "$srcdir/build"
cmake -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr" \
-DINSTALL_LIBS=ON \