summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Koloska2015-07-07 23:35:55 +0200
committerUwe Koloska2015-07-07 23:35:55 +0200
commit363cbb867eda91ac5f18d30997291d41f86da43b (patch)
tree055d35aa33340093ab078e9b95e154bde44d28cb
downloadaur-363cbb867eda91ac5f18d30997291d41f86da43b.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--CMakeLists.patch11
-rw-r--r--PKGBUILD49
-rw-r--r--lomse_config.patch14
4 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4a6fcbe5511
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = liblomse
+ pkgdesc = A music score renderization/edition library
+ pkgver = 0.14.0
+ pkgrel = 2
+ url = http://www.lenmus.org/en/lomse/intro
+ arch = i686
+ arch = x86_64
+ groups = devel
+ license = custom:BSD 2-clause
+ makedepends = bzr
+ makedepends = cmake>=2.8
+ makedepends = unittestpp
+ makedepends = boost>=1.42
+ depends = freetype2>=2.3.5
+ depends = boost-libs>=1.42
+ depends = zlib
+ depends = libpng
+ source = lomse_config.patch
+ source = CMakeLists.patch
+ md5sums = 98f467a21a2926cb72b5abd4a0b07a39
+ md5sums = bc0b1e163fc215680973f1f0f82bcca7
+
+pkgname = liblomse
+
diff --git a/CMakeLists.patch b/CMakeLists.patch
new file mode 100644
index 000000000000..9466f595f230
--- /dev/null
+++ b/CMakeLists.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt_orig 2014-02-12 16:54:45.032757034 +0100
++++ CMakeLists.txt 2014-02-12 16:55:14.981684975 +0100
+@@ -310,7 +310,7 @@
+
+ # Check for Boost >= 1.42.0
+ set(Boost_ADDITIONAL_VERSIONS "1.42" "1.42.0" "1.43" "1.43.0" "1.44" "1.44.0"
+- "1.45" "1.45.0" "1.46" "1.46.0" "1.47" "1.47.0" "1.48" "1.48.0""1.49" "1.49.0"
++ "1.45" "1.45.0" "1.46" "1.46.0" "1.47" "1.47.0" "1.48" "1.48.0" "1.49" "1.49.0"
+ "1.50" "1.50.0" "1.51" "1.51.0" "1.52" "1.52.0" )
+ #set(Boost_USE_STATIC_LIBS OFF)
+ #set(Boost_USE_MULTITHREADED OFF)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e149f38461f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Uwe Koloska <kolewu@koloro.de>
+
+pkgname=liblomse
+pkgver=0.14.0
+pkgrel=2
+pkgdesc="A music score renderization/edition library"
+arch=('i686' 'x86_64')
+url="http://www.lenmus.org/en/lomse/intro"
+license=('custom:BSD 2-clause')
+groups=('devel')
+depends=('freetype2>=2.3.5' 'boost-libs>=1.42' 'zlib' 'libpng')
+makedepends=('bzr' 'cmake>=2.8' 'unittestpp' 'boost>=1.42')
+
+source=('lomse_config.patch'
+ 'CMakeLists.patch')
+md5sums=('98f467a21a2926cb72b5abd4a0b07a39'
+ 'bc0b1e163fc215680973f1f0f82bcca7')
+
+_vcsname=lomse
+
+build() {
+ cd "$srcdir"
+
+ if [[ -d "$_vcsname" ]]; then
+ cd "$_vcsname" && bzr clean-tree && bzr pull && bzr update -r $pkgver && bzr revert
+ else
+ bzr branch lp:lomse -r $pkgver
+ fi
+
+ cd "${srcdir}/${_vcsname}"
+ patch < "${srcdir}/lomse_config.patch" || return 1
+ rm -f cmake-modules/FindFreetype.cmake
+
+ cd "${srcdir}"
+ rm -rf build
+ mkdir build
+ cd build
+
+ cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ../$_vcsname
+
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ DESTDIR="${pkgdir}/" make install
+
+ install -D -m644 "${srcdir}/${_vcsname}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
diff --git a/lomse_config.patch b/lomse_config.patch
new file mode 100644
index 000000000000..eb257f873b18
--- /dev/null
+++ b/lomse_config.patch
@@ -0,0 +1,14 @@
+--- lomse_config.h.cmake_orig 2013-04-02 16:54:36.656405089 +0200
++++ lomse_config.h.cmake 2013-04-02 16:54:50.379224261 +0200
+@@ -37,10 +37,8 @@
+
+
+ //---------------------------------------------------------------------------------------
+-// paths, for test scores and for fonts
++// path for fonts
+ //---------------------------------------------------------------------------------------
+-#define TESTLIB_SCORES_PATH @TESTLIB_SCORES_PATH@
+-#define TESTLIB_FONTS_PATH @TESTLIB_FONTS_PATH@
+ #define LOMSE_FONTS_PATH @LOMSE_FONTS_PATH@
+
+