summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Koloska2015-12-14 00:05:18 +0100
committerUwe Koloska2015-12-14 00:05:18 +0100
commit67e9817963077ba1a84b6f1d96ae4af91060369a (patch)
tree5280429f43f603f45c3cf29aa25d7ea8db36565c
parent363cbb867eda91ac5f18d30997291d41f86da43b (diff)
downloadaur-67e9817963077ba1a84b6f1d96ae4af91060369a.tar.gz
new version 0.16.1
this version is now included in the source for lenmus, so it is not necessary anymore to install this package to build lenmus
-rw-r--r--.SRCINFO14
-rw-r--r--CMakeLists.patch11
-rw-r--r--PKGBUILD29
-rw-r--r--lomse_config.patch14
4 files changed, 13 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4a6fcbe5511..e7405b0ba285 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Dec 13 23:04:23 UTC 2015
pkgbase = liblomse
pkgdesc = A music score renderization/edition library
- pkgver = 0.14.0
- pkgrel = 2
+ pkgver = 0.16.1
+ pkgrel = 3
url = http://www.lenmus.org/en/lomse/intro
arch = i686
arch = x86_64
@@ -13,12 +15,8 @@ pkgbase = liblomse
makedepends = boost>=1.42
depends = freetype2>=2.3.5
depends = boost-libs>=1.42
- depends = zlib
- depends = libpng
- source = lomse_config.patch
- source = CMakeLists.patch
- md5sums = 98f467a21a2926cb72b5abd4a0b07a39
- md5sums = bc0b1e163fc215680973f1f0f82bcca7
+ source = bzr+lp:lomse#revision=0.16.1
+ md5sums = SKIP
pkgname = liblomse
diff --git a/CMakeLists.patch b/CMakeLists.patch
deleted file mode 100644
index 9466f595f230..000000000000
--- a/CMakeLists.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt_orig 2014-02-12 16:54:45.032757034 +0100
-+++ CMakeLists.txt 2014-02-12 16:55:14.981684975 +0100
-@@ -310,7 +310,7 @@
-
- # Check for Boost >= 1.42.0
- set(Boost_ADDITIONAL_VERSIONS "1.42" "1.42.0" "1.43" "1.43.0" "1.44" "1.44.0"
-- "1.45" "1.45.0" "1.46" "1.46.0" "1.47" "1.47.0" "1.48" "1.48.0""1.49" "1.49.0"
-+ "1.45" "1.45.0" "1.46" "1.46.0" "1.47" "1.47.0" "1.48" "1.48.0" "1.49" "1.49.0"
- "1.50" "1.50.0" "1.51" "1.51.0" "1.52" "1.52.0" )
- #set(Boost_USE_STATIC_LIBS OFF)
- #set(Boost_USE_MULTITHREADED OFF)
diff --git a/PKGBUILD b/PKGBUILD
index 6e149f38461f..b7aeaac54a5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,27 @@
# Maintainer: Uwe Koloska <kolewu@koloro.de>
pkgname=liblomse
-pkgver=0.14.0
-pkgrel=2
+pkgver=0.16.1
+pkgrel=3
pkgdesc="A music score renderization/edition library"
arch=('i686' 'x86_64')
url="http://www.lenmus.org/en/lomse/intro"
license=('custom:BSD 2-clause')
groups=('devel')
-depends=('freetype2>=2.3.5' 'boost-libs>=1.42' 'zlib' 'libpng')
+depends=('freetype2>=2.3.5' 'boost-libs>=1.42')
makedepends=('bzr' 'cmake>=2.8' 'unittestpp' 'boost>=1.42')
-
-source=('lomse_config.patch'
- 'CMakeLists.patch')
-md5sums=('98f467a21a2926cb72b5abd4a0b07a39'
- 'bc0b1e163fc215680973f1f0f82bcca7')
-
_vcsname=lomse
-build() {
- cd "$srcdir"
-
- if [[ -d "$_vcsname" ]]; then
- cd "$_vcsname" && bzr clean-tree && bzr pull && bzr update -r $pkgver && bzr revert
- else
- bzr branch lp:lomse -r $pkgver
- fi
-
- cd "${srcdir}/${_vcsname}"
- patch < "${srcdir}/lomse_config.patch" || return 1
- rm -f cmake-modules/FindFreetype.cmake
+source=("bzr+lp:${_vcsname}#revision=${pkgver}")
+md5sums=('SKIP')
+build() {
cd "${srcdir}"
rm -rf build
mkdir build
cd build
- cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ../$_vcsname
+ cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release "../$_vcsname"
make
}
diff --git a/lomse_config.patch b/lomse_config.patch
deleted file mode 100644
index eb257f873b18..000000000000
--- a/lomse_config.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- lomse_config.h.cmake_orig 2013-04-02 16:54:36.656405089 +0200
-+++ lomse_config.h.cmake 2013-04-02 16:54:50.379224261 +0200
-@@ -37,10 +37,8 @@
-
-
- //---------------------------------------------------------------------------------------
--// paths, for test scores and for fonts
-+// path for fonts
- //---------------------------------------------------------------------------------------
--#define TESTLIB_SCORES_PATH @TESTLIB_SCORES_PATH@
--#define TESTLIB_FONTS_PATH @TESTLIB_FONTS_PATH@
- #define LOMSE_FONTS_PATH @LOMSE_FONTS_PATH@
-
-