summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Koloska2016-09-03 22:53:02 +0200
committerUwe Koloska2016-09-03 22:53:02 +0200
commit7bc34ce51728b7f3bcae22086bf2c283caaf2897 (patch)
treed97f9497a9c7c7c79f24ecd20e92d76c0a485353
parentb18522574187348f543784dad27382fd18110814 (diff)
downloadaur-7bc34ce51728b7f3bcae22086bf2c283caaf2897.tar.gz
new version 0.20.0
-rw-r--r--.SRCINFO12
-rw-r--r--CMakeLists_version.patch18
-rw-r--r--PKGBUILD17
3 files changed, 10 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d2f69c4123b..11564ca8d0a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Feb 27 01:51:35 UTC 2016
+# Sat Sep 3 20:31:34 UTC 2016
pkgbase = liblomse
pkgdesc = A music score renderization/edition library
- pkgver = 0.17
- pkgrel = 4
+ pkgver = 0.20.0
+ pkgrel = 5
url = http://www.lenmus.org/en/lomse/intro
arch = i686
arch = x86_64
@@ -14,10 +14,8 @@ pkgbase = liblomse
makedepends = boost>=1.42
depends = freetype2>=2.3.5
depends = boost-libs>=1.42
- source = https://codeload.github.com/lenmus/lomse/tar.gz/0.17
- source = CMakeLists_version.patch
- md5sums = 60f990492a5cccffa815e2c5bf29c517
- md5sums = 3720545fd4350dbd01f8b48958bf9ff8
+ source = https://codeload.github.com/lenmus/lomse/tar.gz/0.20.0
+ md5sums = 76c8dc0ab0d3d00d76908c30e5a5c4c9
pkgname = liblomse
diff --git a/CMakeLists_version.patch b/CMakeLists_version.patch
deleted file mode 100644
index 50c6d75fe053..000000000000
--- a/CMakeLists_version.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- CMakeLists__orig.txt 2016-02-27 02:20:14.180277751 +0100
-+++ CMakeLists.txt 2016-02-27 02:22:44.665204833 +0100
-@@ -123,7 +123,14 @@
-
-
- # Get version information from Git repository
--include( ${LOMSE_ROOT_DIR}/lomse-version-from-git.cmake )
-+#include( ${LOMSE_ROOT_DIR}/lomse-version-from-git.cmake )
-+set(DESCRIPTION "0.17-0-g7d66e99")
-+set(LOMSE_PACKAGE_VERSION "0.17.0")
-+set(LOMSE_VERSION_MAJOR 0)
-+set(LOMSE_VERSION_MINOR 17)
-+set(LOMSE_VERSION_PATCH 0)
-+set(LOMSE_VERSION_SHA1 "g7d66e99")
-+string(TIMESTAMP LOMSE_BUILD_DATE "%Y-%m-%d %H:%M:%S UTC" UTC)
-
- # define build options and create the include file "lomse_config.h"
- include( ${LOMSE_ROOT_DIR}/build-options.cmake )
diff --git a/PKGBUILD b/PKGBUILD
index eabcf6e793c8..8ba316a43099 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Uwe Koloska <kolewu@koloro.de>
pkgname=liblomse
-pkgver=0.17
-pkgrel=4
+pkgver=0.20.0
+pkgrel=5
pkgdesc="A music score renderization/edition library"
arch=('i686' 'x86_64')
url="http://www.lenmus.org/en/lomse/intro"
@@ -12,15 +12,8 @@ depends=('freetype2>=2.3.5' 'boost-libs>=1.42')
makedepends=('cmake>=2.8' 'unittestpp' 'boost>=1.42')
_vcsname=lomse
-source=("https://codeload.github.com/lenmus/lomse/tar.gz/${pkgver}"
- CMakeLists_version.patch)
-md5sums=('60f990492a5cccffa815e2c5bf29c517'
- '3720545fd4350dbd01f8b48958bf9ff8')
-
-prepare() {
- cd "$srcdir/${_vcsname}-${pkgver}"
- patch -p0 -i "$srcdir"/CMakeLists_version.patch
-}
+source=("https://codeload.github.com/lenmus/lomse/tar.gz/${pkgver}")
+md5sums=('76c8dc0ab0d3d00d76908c30e5a5c4c9')
build() {
cd "${srcdir}"
@@ -37,5 +30,5 @@ package() {
cd "${srcdir}/build"
DESTDIR="${pkgdir}/" make install
- install -D -m644 "${srcdir}/${_vcsname}-${pkgver}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -D -m644 "${srcdir}/${_vcsname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}