summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Koloska2016-02-27 02:51:59 +0100
committerUwe Koloska2016-02-27 02:51:59 +0100
commitb18522574187348f543784dad27382fd18110814 (patch)
tree0aeb4cacee1a7c93981787386198e280ff70f0c3
parent67e9817963077ba1a84b6f1d96ae4af91060369a (diff)
downloadaur-b18522574187348f543784dad27382fd18110814.tar.gz
new version 0.17 and change to github
-rw-r--r--.SRCINFO13
-rw-r--r--CMakeLists_version.patch18
-rw-r--r--PKGBUILD21
3 files changed, 39 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7405b0ba285..1d2f69c4123b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
# Generated by mksrcinfo v8
-# Sun Dec 13 23:04:23 UTC 2015
+# Sat Feb 27 01:51:35 UTC 2016
pkgbase = liblomse
pkgdesc = A music score renderization/edition library
- pkgver = 0.16.1
- pkgrel = 3
+ pkgver = 0.17
+ pkgrel = 4
url = http://www.lenmus.org/en/lomse/intro
arch = i686
arch = x86_64
groups = devel
license = custom:BSD 2-clause
- makedepends = bzr
makedepends = cmake>=2.8
makedepends = unittestpp
makedepends = boost>=1.42
depends = freetype2>=2.3.5
depends = boost-libs>=1.42
- source = bzr+lp:lomse#revision=0.16.1
- md5sums = SKIP
+ source = https://codeload.github.com/lenmus/lomse/tar.gz/0.17
+ source = CMakeLists_version.patch
+ md5sums = 60f990492a5cccffa815e2c5bf29c517
+ md5sums = 3720545fd4350dbd01f8b48958bf9ff8
pkgname = liblomse
diff --git a/CMakeLists_version.patch b/CMakeLists_version.patch
new file mode 100644
index 000000000000..50c6d75fe053
--- /dev/null
+++ b/CMakeLists_version.patch
@@ -0,0 +1,18 @@
+--- CMakeLists__orig.txt 2016-02-27 02:20:14.180277751 +0100
++++ CMakeLists.txt 2016-02-27 02:22:44.665204833 +0100
+@@ -123,7 +123,14 @@
+
+
+ # Get version information from Git repository
+-include( ${LOMSE_ROOT_DIR}/lomse-version-from-git.cmake )
++#include( ${LOMSE_ROOT_DIR}/lomse-version-from-git.cmake )
++set(DESCRIPTION "0.17-0-g7d66e99")
++set(LOMSE_PACKAGE_VERSION "0.17.0")
++set(LOMSE_VERSION_MAJOR 0)
++set(LOMSE_VERSION_MINOR 17)
++set(LOMSE_VERSION_PATCH 0)
++set(LOMSE_VERSION_SHA1 "g7d66e99")
++string(TIMESTAMP LOMSE_BUILD_DATE "%Y-%m-%d %H:%M:%S UTC" UTC)
+
+ # define build options and create the include file "lomse_config.h"
+ include( ${LOMSE_ROOT_DIR}/build-options.cmake )
diff --git a/PKGBUILD b/PKGBUILD
index b7aeaac54a5f..eabcf6e793c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,26 @@
# Maintainer: Uwe Koloska <kolewu@koloro.de>
pkgname=liblomse
-pkgver=0.16.1
-pkgrel=3
+pkgver=0.17
+pkgrel=4
pkgdesc="A music score renderization/edition library"
arch=('i686' 'x86_64')
url="http://www.lenmus.org/en/lomse/intro"
license=('custom:BSD 2-clause')
groups=('devel')
depends=('freetype2>=2.3.5' 'boost-libs>=1.42')
-makedepends=('bzr' 'cmake>=2.8' 'unittestpp' 'boost>=1.42')
+makedepends=('cmake>=2.8' 'unittestpp' 'boost>=1.42')
_vcsname=lomse
-source=("bzr+lp:${_vcsname}#revision=${pkgver}")
-md5sums=('SKIP')
+source=("https://codeload.github.com/lenmus/lomse/tar.gz/${pkgver}"
+ CMakeLists_version.patch)
+md5sums=('60f990492a5cccffa815e2c5bf29c517'
+ '3720545fd4350dbd01f8b48958bf9ff8')
+
+prepare() {
+ cd "$srcdir/${_vcsname}-${pkgver}"
+ patch -p0 -i "$srcdir"/CMakeLists_version.patch
+}
build() {
cd "${srcdir}"
@@ -21,7 +28,7 @@ build() {
mkdir build
cd build
- cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release "../$_vcsname"
+ cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release "../${_vcsname}-${pkgver}"
make
}
@@ -30,5 +37,5 @@ package() {
cd "${srcdir}/build"
DESTDIR="${pkgdir}/" make install
- install -D -m644 "${srcdir}/${_vcsname}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -D -m644 "${srcdir}/${_vcsname}-${pkgver}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}